I am trying to run a package on my Raspberry Pi:

At the terminal, I typed in “sudo apt-get install picap” followed by enter.

I get it installed but cannot execute "picap-setup" – instead an error message follows:

pi@raspberrypi:~ $ picap-setup Traceback (most recent call last): File "", line 1, in ImportError: No module named RPi

Python-dev and Rpi.GPIO are installed on the Pi. I also updated the Pi with the latest version with sudo apt-get update and sudo apt-get dist-upgrade.

Picap comes from : https://www.bareconductive.com/make/setting-up-pi-cap-raspberry-pi/

I am thankful for any hints.

  • do you have pip installed???
    – BetaDev
    Commented Feb 3, 2017 at 18:21

5 Answers 5


First of all, repeat following process

sudo apt-get install python-pip
pip freeze | grep RPi

see what you get after this second command, If you get a valid module for RPi.GPIO or not. And then following if not installed.

For Python 2

sudo apt-get install python-dev python-rpi.gpio


pip install RPi.GPIO

For python3

sudo apt-get install python3-dev python3-rpi.gpio

and then ( for python 2 or python 3):

sudo apt-get install picap

These all worked for me, Just you need to verify pip freeze | grep RPi. And one more thing sometimes some modules are not available for normal user only for root user. Make sure. I did all above using my pi user.

  • 2
    I would not use pip to install to system packages, either install from system package manager with apt or use virtualenv if you want to use pip.
    – crasic
    Commented Dec 18, 2017 at 17:13
  • Yeah thats correct, agreed
    – BetaDev
    Commented Dec 18, 2017 at 17:15
  • 2
    For Python3 use sudo apt-get install python3-dev python3-rpi.gpio. Commented Sep 29, 2019 at 15:49
  • @crasic Could you explain why or point me in the direction of an explanation for simpletons? Thanks. Commented Jan 25, 2020 at 20:31
  • I get the following when trying to run picap-setup on my Raspberry Pi 4 with Python 3.7 in a virtualenv: File "<stdin>", line 2 print GPIO.RPI_INFO['TYPE'] ^ SyntaxError: Missing parentheses in call to 'print'. Did you mean print(GPIO.RPI_INFO['TYPE'])?. It seems like this doesn't work with Python 3
    – lolsky
    Commented Dec 2, 2020 at 4:34

If Python RPi module is missing, one can install pip with all dependencies and then install the module using pip or go with the better approach and install the module alone:

sudo apt-get install python-rpi.gpio

for Python3 this one:

sudo apt-get install python3-rpi.gpio
  • Some appliances/JeOS doesn't support distro upgrade (like Volumio) and updating and installing a lot of dependencies can break the system, so this is another reason why to go low profile like that.
    – dmnc
    Commented Mar 12, 2019 at 11:46

For Windows

pip install python3-rpi.gpio


pip install RPi.GPIO

I had a similar issue with my Pi. Doing a simple pip install solved the issue.

pip install RPi.GPIO 
  • 4
    This just repeats answers from 1 year ago. Commented Mar 21, 2020 at 10:47

if using pycharm on windows then it will work like this

  1. upgrade pip

    C:\Users\sandeep\PycharmProjects\newnum1\venv\Scripts\python.exe -m pip install --upgrade pip

  2. installing the module

    pip install RPi.GPIO

  3. it worked for me should work for everyone

  • That answer has already been given - twice.
    – Chenmunka
    Commented May 19, 2022 at 10:47
  • any of those didn't work for me so i provided my version that worked perfectly
    – Jangir
    Commented May 19, 2022 at 12:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.