1

I know there's lots of questions like this one but I have tried everything from the other questions and it's no help.

I have just flashed the newest image from the Raspberry Pi Website onto an SD card. Then it boots up with an error:

Kernel panic - not syncing: VFS: Unable to mount fs on unknown-block(179,2) CPU: 0 PID: 1 Comm: swapper Not tainted 4.4.34+ #930 Hardware name: BCM2708 [<c0016cfc>] (unwind_backtrace) from [<c0013c20>] (show_stack+0x20/0x24) [<c0013c20>] (show_stack) from [<c02e437c>] (dump_stack+0x20/0x28) [<c02e437c>] (dump_stack) from [<c00d74f4>] (panic+0x8c/0x1f4) [<c00d74f4>] (panic) from [<c07c2384>] (mount_block_root+0x218/0x260) [<c07c2384>] (mount_block_root) from [<c07c25c8>] (mount_root+0x100/0x12c) [<c07c25c8>] (mount_root) from [<c07c2760>] (prepare_namespace+0x16c/0x1d0) [<c07c1f1c>] (prepare_namespace) from [<c07c1f1c>] (kernel_init_freeable+0x208/0x254) [<c07c1f1c>] (kernel_init_freeable) from [<c05716b4>] (kernel_init+0x18/0xfc) [<c05716b4>] (kernel_init) from [<c000f8a8>] (ret_from_fork+0x14/0x2c) ---[ end Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(179,2) random: nonblocking pool is initialized

I was using 2016-09-23-raspbian-jessie-lite.img which worked about 4 days before so decided to reflash with the latest 2017-01-11-raspbian-jessie-lite.img and still got this error.

I have tried:

  • Different SD cards
  • Different Pi Zeros (1st and 2nd versions)
  • Different Power Sources
  • Using a powered (and non-powered) HDMI to VGA adapter
  • Different images (stated above)

I really don't know how to fix this. I have a feeling I might have fried my Pi or SD card. I am using Etcher to write the SD cards and I am using Windows 64-bit.

I am really confused because I used the same software and images, as I said, about 4 days before and it was fine.

  • What SD cards are you using? What were the different power sources you tried? I'm assuming between each time you wrote the image to the SD card you formatted it all the way to factory settings? – Darth Vader Jan 22 '17 at 15:54
  • I have tried 2 x Toshiba Exceria 8GB Class 1 Cards and a 8GB Class 4 Card. I have tried an Official Pi Adapter, some other various power bricks for phones, etc and also my laptop. I'm not sure how you format it 'all the way to factory settings' though – Jake Walker Jan 22 '17 at 16:02
  • If you put your imaged SD card into a Windows computer the full size of the SD card won't show up. (Because in the process of imaging it was formatted to a Linux file-system). Using software that can read the different partitions on the SD card, you need to remove those partitions and set the SD card so it has one partition which is the full size of the SD card. You then need to open File Explorer, right click on the SD card and select the format option. For the options it gives you select default. Once that is finished you can image the SD card. – Darth Vader Jan 22 '17 at 16:15
  • As a side note the faster the SD card the better, it will give you a much smoother experience in Raspbian. So I suggest trying what I suggested with the Class 4 card. – Darth Vader Jan 22 '17 at 16:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.