0

I want to install GitLib on my Raspi 3 running Ubuntu Mate 16.04. For this, I followed the steps described for Ubuntu 16.04: https://about.gitlab.com/downloads/#ubuntu1604

Step 1 worked as expected. However, I ran into trouble in step 2:

christoph@christoph-pi:/tmp$ curl -sS https://packages.gitlab.com/install/repositories/gitlab/gitlab-ce/script.deb.sh | sudo bash
[sudo] password for christoph: 
Detected operating system as Ubuntu/xenial.
Checking for curl...
Detected curl...
Running apt-get update... done.
Installing apt-transport-https... done.
Installing /etc/apt/sources.list.d/gitlab_gitlab-ce.list...done.
Importing packagecloud gpg key... done.
Running apt-get update... done.

The repository is setup! You can now install packages.
christoph@christoph-pi:/tmp$ sudo apt-get install gitlab-ce
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package gitlab-ce

Switching out apt-get for apt doesn't work. I tried executing

sudo apt update
sudo apt-get update

and then trying to install gitlab-ce but it doesn't work, either.

The installation instructions for the Raspi 2 mention the same package.

How do I install GitLab? Is the Raspi 3 not supported or does it not work because I'm using Ubuntu Mate?

1

You might want to check what GitLab actually put in your apt sources. if you take a look in /etc/apt/sources.list.d/ you should see a gitlab entry. It should include raspberry pi in it somewhere. It may have mistaken Ubuntu Mate as the x86 version and apt is giving up. The link you posted looks a lot like the instructions for x86 (rather than ARM).

The Pi instructions are here

The install script itself more-or-less just runs: (you can view it here https://packages.gitlab.com/install/repositories/gitlab/raspberry-pi2/script.deb.sh - my line numbers are as per this file)

Add signing key (line 107):

curl -L "https://packages.gitlab.com/gitlab/raspberry-pi2/gpgkey" | sudo apt-key add -

Add Repos (line 108) from https://packages.gitlab.com/install/repositories/gitlab/raspberry-pi2/config_file.list?os=ubuntu&dist=xenial&source=script

which puts

deb https://packages.gitlab.com/gitlab/raspberry-pi2/ubuntu/ xenial main
deb-src https://packages.gitlab.com/gitlab/raspberry-pi2/ubuntu/ xenial main

in /etc/apt/sources.list.d/gitlab_raspberry-pi2.list

Then sudo apt-get update

Then you should see gitlab-ce available.

My experiance with GitLab on the Pi wasn't too good, GitLab itself is great but i don't think the Pi is really up to it, mostly due to the limited memory.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.