1

I bought myself this, https://shop.pimoroni.com/products/esp8266-phat.

I started with looking through this blog post, http://richardhayler.blogspot.nl/2016/02/getting-started-with-esp8266-iot-phat.html. At point number 5.

5. We need to stop the Pi using the Serial port for console messages. Edit /boot/cmdline.txt to remove 'console=ttyAMA0' from the line. You should be left with:

dwc_otg.lpm_enable=0 console=tty1 root=/dev/mmcblk0p2 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait

Instead of console=ttyAMA0 I have this console=serial0,115200. Then, I tried with AND without console=serial0,115200 in my /boot/cmdline.txt. I am pretty sure the serial connection is disabled as well.

As the tutorial says, I tried to run my ESP8266 pHat with minicom -b 115200 -o -D /dev/ttyAMA0. But it does not working (after I pressed enter there is a delay and then the program closes). Since I do not have /dev/ttyAMA0 I tried with /dev/serial0 still does not working.

I tried to run installation from curl -sS get.pimoroni.com/iotphat | bash as well but same thing happened.

I am using latest Raspbian Jessie and Raspberry PI 3 Model B

5
  • That might be related, but I am not sure what should I do after reading that :(. – notalentgeek Jan 23 '17 at 19:49
  • Added core_freq=250 in /boot/config.txt still the same result after reboot. – notalentgeek Jan 23 '17 at 19:56
  • Take away point is that by default ttyAMA0 is occupied by the bluetooth, and serial0 corresponds to a potentially less reliably timed "mini UART" -- but you can swap them back with a device tree overlay in config.txt. Minicom seems to be "fussier" than other serial interaces such as screen; I'm not sure if I ever got it to work with an ESP8266. The thing with which I've had the most success is miniterm.py, which I think you will get if you apt install python-serial. – goldilocks Jan 23 '17 at 19:57
  • Hey mate, it is working by putting these in /boot/config.txt, dtoverlay=pi3-disable-bt and enable_uart=1. Thanks. – notalentgeek Jan 23 '17 at 20:11
1

it is working by putting dtoverlay=pi3-disable-bt and enable_uart=1 in /boot/config.txt.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.