0
  1. The driver download page is here, http://www.tp-link.com/us/download/Archer-T1U.html#Driver.
  2. In the .pdf instruction it says that I need to edit configuration in makefile.c.
  3. However, there is no makefile.c, instead there is Makefile.inc with the same content as described in .pdf instruction.
  4. So, I assume the makefile.c mentioned in the .pdf instruction is actually Makefile.inc.
  5. I changed nothing in the Makefile.inc.
  6. I run sudo make. It returns error *** /lib/modules/4.4.38-v7+/build: No such file or directory. Stop.
  7. Copy Makefile.inc into makefile.c, then run sudo make again, same result.

    • lsusb returns Bus 001 Device 007: ID 2357:0105 for this dongle.
    • I use Raspbian Jessie. Currently attaching this in my Raspberry PI 3. However, I will use this dongle in Raspberry PI Zero.
    • I suspect that I choose wrong target platform. At this case I choose PC as the target platform in Makefile.inc.

Here are other target platform in the Makefile.inc.

  • PC
  • 5VT
  • IKANOS_V160
  • IKANOS_V180
  • SIGMA
  • SIGMA_8622
  • INIC
  • STAR
  • IXP
  • INF_TWINPASS
  • INF_DANUBE
  • INF_AR9
  • INF_VR9
  • BRCM_6358
  • INF_AMAZON_SE
  • CAVM_OCTEON
  • CMPC
  • RALINK_2880
  • RALINK_3052
  • SMDK
  • RMI
  • RMI_64
  • KODAK_DC
  • DM6446
  • FREESCALE8377
  • BL2384
  • BL23570
  • BLUBB
  • BLPMP
  • MT85XX
  • MT53XX
  • NXP_TV550
  • MVL5
  • RALINK_3352
  • UBICOM_IPX8
  • INTELP6

EDIT 1, I tried to install this in my Ubuntu MATE 16.04 laptop, with same settings as above. This returns these errors.

cc1: some warnings being treated as errors
scripts/Makefile.build:258: recipe for target '/home/xxxxx/Downloads/Archer_T1U_V1_150909/Driver/MODULE/os/linux/../../sta/sta_cfg.o' failed
make[3]: *** [/home/xxxxx/Downloads/Archer_T1U_V1_150909/Driver/MODULE/os/linux/../../sta/sta_cfg.o] Error 1
Makefile:1420: recipe for target '_module_/home/xxxxx/Downloads/Archer_T1U_V1_150909/Driver/MODULE/os/linux' failed
make[2]: *** [_module_/home/xxxxx/Downloads/Archer_T1U_V1_150909/Driver/MODULE/os/linux] Error 2
make[2]: Leaving directory '/usr/src/linux-headers-4.4.0-59-generic'
Makefile:548: recipe for target 'osdrv' failed
make[1]: *** [osdrv] Error 2
make[1]: Leaving directory '/home/xxxxx/Downloads/Archer_T1U_V1_150909/Driver/MODULE'
Makefile:3: recipe for target 'all' failed
make: *** [all] Error 2
2
  • 1
    Splurge $15 on a known working adapter. Out-of-tree drivers on linux fall into one or both of two categories 1) Proprietary closed source things; 2) Stuff that was never submitted, or rejected, for inclusion in the mainline kernel. The former tend to be impossible on the Pi because they are pre-compiled for x86(-64); at a glance this isn't that. The stuff in the second category is likely to be poorly written and maintained. In any case, this is probably only the beginning of your headache; it is then a matter of how many hours you want to waste before you give up.
    – goldilocks
    Commented Jan 24, 2017 at 15:35
  • My WiPi in on the way. Commented Jan 24, 2017 at 15:50

1 Answer 1

1

About five hours of searching and about 6GB of downloads later (one guide had me download the entire kernel source, 2.5GB as well as a bunch of different versions of it) I got!

MrEngman on the Raspberry Pi forums is godsend, he made a script which automatically selects the correct wifi driver for the kernel and installs it.

Here's what to do:

  1. Download http://www.fars-robotics.net/install-wifi to your pi. It's a shell script. The rest of the instructions are copied from the top of the script:
  2. sudo mv install-wifi /usr/bin/install-wifi
  3. sudo chmod +x /usr/bin/install-wifi
  4. sudo install-wifi

This works perfectly for me. It also supports monitor mode which is awesome! I've verified that it works on 4.9.41-v7+ and the bleeding edge build 4.9.54+

2
  • Will this work with all consumer WiFi dongle or just the specific ones? I ended up buying WiPi for my Raspberry PI Zero. This was before RPI Zero W released. Thanks for posting regardless. Commented Oct 15, 2017 at 12:47
  • He has compiled a specific set of drivers. The majority of usb cards work out of the box with raspbian though.
    – Allison
    Commented Oct 15, 2017 at 15:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.