2

I am trying to remove all text from the start-up process of the RPi. I have found serveral guides explaining how to do this, and they all say relatively the same thing. Example. Here is my cmdline.txt, according to everything I can find, this should work, however I still am getting about a screens worth of lines on boot up. It should be noted there this is significantly less than what was there initially.

dwc_otg.lpm_enable=0 console=serial0,115200 console=tty3 root=/dev/mmcblk0p2 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait loglevel=3 logo.nologo vt.global_cursor_default=0 quiet

3 Answers 3

1

A hardware solution: get an HDMI extender or switch with an on-off button, and activate it via GPIO when the Pi is fully booted.

Perhaps it could be possible to simply cut a wire in the HDMI cable which you would then reconnect with a relay. No idea which one though. Cutting the clock will disable the HDMI for sure, but I'm not certain HDMI will work well if you route the clock through a relay.

0

Anther way to remove most of the text is by enabling the splash screen sudo raspi-config then boot options then splash screen. This wont remove all text but will remove all but 20-30 lines and there is probably some way to switch the standard screen for your own if you'd like.

5
  • Thanks. I am working on a minimal install so "The splash screen is not installed so cannot be activated" Do you know what needs to be installed for it to work? Commented Jan 25, 2017 at 2:11
  • @gleeson it only works on the GUI version
    – sir_ian
    Commented Jan 25, 2017 at 2:16
  • Yes, I am using openbox so all of the little things I have to install manually. So I'm asking if you know what package is used for that. Or is it built in to LXDE or one of them only? Commented Jan 25, 2017 at 2:19
  • I'm fairly certain it is only on Raspbian
    – sir_ian
    Commented Jan 25, 2017 at 2:21
  • So used this method to implement a splash screen, however it didn't remove the text in question. Does anyone else have any suggestions? Commented Jan 25, 2017 at 3:13
0

You should try adding these two options to cmdline.txt:

plymouth.ignore-serial-consoles
loglevel=0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.