0

The Matchbox virtual keyboard is missing the colon character. Is there a solution to add this character?

2
  • 2
    Have you tried pressing SHIFT? – lornix Jan 26 '17 at 12:37
  • @lornix hahahahahahahahahaha A+ answer there. – PNDA Feb 10 '17 at 2:26
1

Per lornix's comment below the question, pressing the shift modifier key should change the semicolon to a colon. I'm reasonably sure that this is the relevant code used in the keyboard-extended.xml file which, I think, is the layout you're using at the moment:

<key fill='false'>
      <default display=";" />
      <shifted display=":" />
</key>

If, for whatever reason, you can't press the shift key and need to make a new layout with a colon, there are some instructions provided on matchbox's Github page:

Making your own keyboard layouts

Keyboard layout files are UTF8 XML files ( Make sure they are saved with this encoding! ). They are loaded from the directory $PREFIX/share/matchbox-keyboard and are named in the format keyboard[-locale][-variant].xml. This can be overridden by setting MB_KBD_CONFIG environment variable to a valid config file path or by creating $HOME/.matchbox/keyboard.xml.

The basic layout of the file looks like;

<keyboard>

<options>
</options>

<layout>
  <row>
    <key ...>       
      <default .. >     
      <shifted .. >     
      <mod1 .. >
      ....    
    <key>
    .... more keys ...    
    <space width="1000" />
  </row>
  <row>
  ...
  </row>
</layout>

</keyboard>

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.