Last night I reinstalled my Raspberry Pi 2 model B with the latest version of Raspbian (Jessie). All went well, but when I tried to install mono by following these instructions, the installation failed.

dpkg: error processing package monodoc-browser (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

Running mono gives me just the following feedback: "illegal instruction".

I never had problems with installing mono on my Pi but maybe it is due to the fact that the latest version of mono is not compatible anymore with ARMv6 architecture of my Raspberry Pi 2. However, I cannot find this information on the website of mono. Mid 2016 it still installed fine on other raspberry pi 2 models.

Do I just need to install an older version from the archive? If yes, which one?

  • On the page you linked to, there are several different instructions for installing, which one did you use? Check this out
    – jogco
    Jan 26, 2017 at 8:04
  • @jogco I just used the first one, i'll try to add the three other repositories as well and will try again. I'll let you know this weekend
    – MichaelK
    Jan 26, 2017 at 10:38
  • Be sure to read the whole Debian, Ubuntu and derivatives section.
    – jogco
    Jan 26, 2017 at 10:43

1 Answer 1


Okay, I think architecture is getting in the way here. If you exactly followed the instructions on the site, undo all of them. I'm sure they're for x86/x64 (your everyday PCs). The Pi is using ARM (comparable to mobile phones).

Best bet would be to reinstall Raspbian.

After that, simply run

sudo apt-get update && sudo apt-get upgrade -y

to update the system, then

sudo apt-get install mono-complete

You should have mono after the installation completes.

  • Thx! this worked.. don't forget to install first the package apt-transport-https and after that mono-complete
    – MichaelK
    Jan 27, 2017 at 17:48
  • but be aware that this is only going to install mono version 3.2.8
    – MichaelK
    Jan 28, 2017 at 11:20
  • I was able to install mono 4.8 on Rpi 3 and run an console app which was compiled on VS2017 (4.5.2), which did not run before. These instruction was a great help: forums.homeseer.com/showthread.php?t=183916
    – thomas nn
    Mar 9, 2017 at 22:32
  • FYI: mono-project has broken/non-existent packages for jessie, which is probably the reason for this whole problem. However, adding the wheezy package list works: echo 'deb http://download.mono-project.com/repo/debian wheezy main' > /etc/apt/sources.list.d/mono.list
    – dualed
    May 2, 2017 at 23:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.