1

As I tried to set up my Raspberry 3 yesterday, I ran into a an interesting issue: the wifi adapter seems to recognise some of the networks available, however, not the one I would like to use. Strangely, the number of different networks around varies dramatically each time I press refresh.

When I run Linux, however, my network is displayed and available.

Thank you in advance

  • Don't refresh too fast. Give it a couple of seconds in between. – PNDA Jan 28 '17 at 2:36
  • I gave it a minute, still, no result... – Michael Heribert Jan 29 '17 at 18:00
  • That's weird indeed. – PNDA Jan 30 '17 at 1:30
1

I think it looks likely that Windows IoT on the Pi suffers from the same problem that Raspbian did when the Pi 3 came out. WiFi channels 12 and 13 aren't legal everywhere, and someone didn't enable them in software.

There's a proposed fix on social.msdn.microsoft.com but there isn't enough followup on the post to figure out if it worked as intended. Note that 'MAX channel is 13...' is a typo which should read 'MAX channel is 11...':

Since there is no device manager UI available you can try changing the channel directly through registry. From the INF file it says MAX channel is 13, but its worth giving it a try.

1) The WiFi driver parameters reside under [HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Class{4d36e972-e325-11ce-bfc1-08002be10318}\000N] On my machine N = 2. To verify it is the WiFi driver, the description should be "Broadcom 802.11n Wireless SDIO Adapter". If it is not \0002, look at the other entries.

2) Once you found the WiFi entry, change the "WFDChannelNumber" value from "11"to "13". 3) Just to be on the safe side, change also [HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Class{4d36e972-e325-11ce-bfc1-08002be10318}\0002\Ndi\Params\WFDChannelNumber] max from "11" to "13"

3) Reboot and check.

If it is the WiFi channel that's causing the problem, you can normally change it (in this case to something below 12) on your router's configuration page. You will almost certainly have to reconnect every other device in the house after doing this.

  • It works now, that seems to be the problem! Thank you very much! – Michael Heribert Jan 31 '17 at 17:45
  • I just changed the Channel in my wifi router to get a listing. And it worked! Yeah, i could add a registry entry. But this works fine. – Marty_in_a_Box Feb 18 '18 at 21:56
0

I had the same issue.

If you have access to router control, you could change Control channel in router settings. In my case I needed to change Control channel form AUTO to 11.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.