I tried installing openGL on my raspberry pi (libgl1-mesa.glx) but every time i try running glxinfo or rendering something i end up with an error:

couldn't find RGB GLX visual or fbconfig

I tried reconfiguring xserver-xorg but it still doesn't work.


For enabling the open source graphics driver that provides OpenGL 2.0 support, there are a few more steps -- as is, you've put in the normal GL library (which is basically a wrapper that loads hardware drivers), but not the userspace or kernel side of the graphics driver. When it doesn't find a hardware graphics driver it falls back to indirect GLX, but that fails because the X Server hasn't initialized a graphics driver either.

The easiest way to get all the necessary steps done is to use sudo raspi-config and choose the "Experimental GL driver", then reboot, which will both enable the kernel driver and install the necessary userspace packages.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.