1

I have had this problem for a while now and have now decided to ask here. I asked on the raspberry pi subreddit, but found no help.

Whenever I try to use apt-get to update or install something, the pi get stuck trying to connect to mirrordirector.raspbian.org.

The terminal looks like this when trying to install jq for example:

pi@raspberry:~ $ sudo apt-get install jq
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following NEW packages will be installed:
   jq
0 upgraded, 1 newly installed, 0 to remove and 4 not upgraded.
Need to get 96.1 kB of archives.
After this operation, 232 kB of additional disk space will be used.
WARNING: The following packages cannot be authenticated!
  jq
Install these packages without verification? [y/N] y
0% [Connecting to mirrordirector.raspbian.org (2001:41c9:1:3ce::11)]

And after a while, I get this:

Err http://mirrordirector.raspbian.org/raspbian/ jessie/main jq armhf    1.4-2.1
  404  Not Found [IP: 5.153.225.207 80]
E: Failed to fetch     http://mirrordirector.raspbian.org/raspbian/pool/main/j/jq/jq_1.4-    2.1_armhf.deb  404  Not Found [IP: 5.153.225.207 80]

E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

As it says on the last line, to try apt-get update, I would, but I get the same result. Getting stuck at 0% thing to connect.

Thanks in advance.

  • 5
    Your problem is almost certainly external to the Pi. It is not uncommon for archives to be unavailable, especially on weekends. Assuming your repositories are up to date it may be a routing problem with your ISP. NOTE You should ALWAYS do sudo apt update BEFORE trying any installation to ensure your repositories are up to date. If this doesn't work post the error message, but the cause is likely the same. PS this does look like the current version of jq. – Milliways Jan 29 '17 at 2:51
  • @Milliways I don't think it's down since it's a 404 error. Also, the authentication failure is another red flag. – PNDA Jan 29 '17 at 2:55
  • Can you access mirrordirector.raspbian.org on your network from another machine? – Gregology Jan 29 '17 at 14:07
  • @Gregology Yes. I can access it – Ian Thompson Jan 29 '17 at 17:41
1

If I look at http://mirrordirector.raspbian.org/raspbian/pool/main/j/jq/, the file (http://mirrordirector.raspbian.org/raspbian/pool/main/j/jq/jq_1.4-2.1_armhf.deb) that the package try to update simply doesn't exist or no longer available. The closest file for arm-core debian package is jq_1.4-2.1+deb8u1_armhf.deb. The file name shown up on the 404 error message also has some straight spaces in between the file name jq_1.4- 2.1_armhf.deb. If you have already tried running sudo apt-get update --fix-missing, then you probably have to manually locate the jq package info and fix it using sudo nano /var/lib/dpkg/status.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.