0

I have fixed my sense HAT after bending the male pins of the header. I used a https://shop.pimoroni.com/products/gpio-hammer-header Pimoroni Solderless GPIO Hammer Header

But I tested it and it behaved very oddly

At boot, a rainbow comes up, but keeps throughout the Pi being powered, and I can't program it

I checked how inserted the header into the HAT, and it doesn.t fall off at all

Can I fix it, or should i just ignore it (I have an Enviro pHat, but it doesn't include: Humidity, LED Grid, Gyro and Magnetometer)

Note: I can't solder

  • is the rainbow a small square in the upper right? If so it is indicating under voltage. You need a better power supply or cable. – Steve Robillard Jan 29 '17 at 10:34
  • @SteveRobillard, it's a different rainbow, the Sense HAT LEDs light up in rainbow colours on boot – Gregology Jan 29 '17 at 14:05
  • @SteveRobillard the whole grid lights up, but I'm suspecting it to be slightly dimmer... – R Harrington Jan 29 '17 at 15:31
  • The rainbow on the sense HAT on boot simply means it's powered. It should disappear shortly before the login prompt appears (or X starts). One cause of it not disappearing is I2C being disabled; you can ensure it's enabled with sudo raspi-config – Dave Jones Jan 30 '17 at 10:55
  • @DaveJones I've enable I2C in raspi-config and rebooted my Pi. Still no luck – R Harrington Feb 2 '17 at 11:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.