5

So last week I bought the Raspberry Pi 3 model B with the complete Canakit. I installed Ubuntu 16.04 server standard image on the micro sd card with my Windows computer.

I used SF Formatter to format my micro sd card with the Format Size Adjustement option On. I also used Win32DiskImager to write my image on the micro sd card.

Here's the Ubuntu image file that I used: http://www.finnie.org/software/raspberrypi/ubuntu-rpi3/ubuntu-16.04-preinstalled-server-armhf+raspi3.img.xz

The first boot went well. I used that command to upgrade my Raspberry PI:

sudo apt-get update && sudo apt-get dist-upgrade

After that, I rebooted my Raspberry PI and it always got stuck on the u-boot screen. It's like it can't find the OS.

I can add the error code tonight when I get home. I've tried it multiple time and it didn't worked everytime. I also have a Macbook Pro, so if it changed anything I can try to format and write on my micro sd card with it.

Update 1: Here's the error message that I am talking about. It occur when I boot my Raspberry Pi 3 with my Ubuntu Server 16.04 standard upgraded. u-boot error

  • 1
    I got exactly the same problem, and I used apt-get upgrade (not dist-upgrade) – Anders Alkmar Feb 15 '17 at 22:51
  • 1
    Same situation here, even running only "apt-get upgrade" breaks your install the next reboot! – Jan Van Ham Feb 22 '17 at 20:31
2

I had the same problem. In my case, the following instructions fixed the problem:

  • install, boot, sudo apt upgrade, reboot
  • u-boot error
  • plug microSD to PC
  • edit 'device_tree_address' on config.txt
    # original
    device_tree_address=0x100
    device_tree_end=0x8000

    # modified
    device_tree_address=0x02008000
  • insert microSD to Pi3 again
  • boot

References: https://bugs.launchpad.net/ubuntu/+source/linux-raspi2/+bug/1652270 https://bugs.launchpad.net/ubuntu/+source/linux-raspi2/+bug/1652270/comments/34

  • In my case, I had to comment out device_tree_end=0x8000 to get it working, this is also mentioned in your references. – lunatikz Sep 3 '17 at 14:39
0

Your problem is attempting to run dist-upgrade.

AFAIK your system is now broken, and your only option is to restore from backup.

dist-upgrade runs the standard Ubuntu upgrade, which tries to install standard boot sector etc.

There does NOT appear to be a version of dist-upgrade for MATE ARM for the Pi.


Edit The latest update to

Operating System: Ubuntu 16.04.2 LTS
Kernel: Linux 4.4.38-v7+

Now includes raspberrypi-bootloader (1.20161215-1~xenial1.0)

Ubuntu MATE seems to have joined Arch and Raspbian in updating kernel (to the latest Foundation supported version) with sudo apt upgrade. This was before the official announcement of the update

(I have not tried what dist-upgrade does on the latest, but there seems to be no need.)

  • Thank you for the answer. Should I use the apt-get upgrade or just let it as the image version? – François Noël Feb 2 '17 at 0:57
  • @FrankNoel you can use upgrade to update software, but this will not update firmware, and you certainly can't update to 16.10. – Milliways Feb 2 '17 at 0:59
  • Would the rpi-update and the upgrade command work? Or should I stay at this version? – François Noël Feb 2 '17 at 1:00
  • rpi-update will upgrade firmware (with the usual caveats about installing possible testing versions). The only way to upgrade to a newer release e.g. 16.10 to to do a fresh install. – Milliways Feb 2 '17 at 1:03
0

i had nearly the same problem as the author.

I have a PI3 here with ubuntu-16.04-preinstalled-server-armhf+raspi3.img installed. Right after doing the update and upgrade procedure (not dist-upgrade) my system was not able to boot up anymore. First i tried to modify my config.txt ( device_tree_address=0x02008000 ) as mentioned earlier by someone else. Unfortunately this did not fix the problem.

So i decided to try something else: I copied over all the files i found in the folder "system-boot" inside my original ubuntu-16.04-preinstalled-server-armhf+raspi3.img file to the sdcard by overwriting existing files. After that my PI was able to boot into xenial again.

Than i tried to use dist-upgrade. After i did reboot, again my system didn't work. Again I first tried the fix that was mentioned before ( device_tree_address=0x02008000 ) and it worked for me. Anyway I also retried the procedure i did before ( overwriting the files in "system-boot" ) and again, it worked.

I am defenitely no computerexpert. So i dont know if this might effect my system with bad behavior in future. But for the moment, i use it as workaround.

EDIT: After some testing i found out that i was unable to detect my wifi-device after doing the dist-upgrade-procedure. To fix this, i did a backup of the file /lib/firmware/brcm/brcmfmac43430-sdio.txt before upgrading. After reboot I copied the file back to it's place (somehow it gets deleted by the system during the upgrade-procedure), did another reboot and now the wifi is back online.

0

Simple = be attention on the information

Edit file...

# original
device_tree_address=0x100
device_tree_end=0x8000

# modified
device_tree_address=0x02008000
#device_tree_end=0x8000

WORKED PERFECTLY !!!

protected by Community Mar 12 '18 at 20:01

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.