1

Last night I followed this guide to upgrade my headless pi server from Jessie to Stretch. Everything worked as expected and the version output is now Stretch:

cat /etc/os-release
PRETTY_NAME="Raspbian GNU/Linux 9 (stretch)"
NAME="Raspbian GNU/Linux"
VERSION_ID="9"
VERSION="9 (stretch)"
ID=raspbian
ID_LIKE=debian
HOME_URL="http://www.raspbian.org/"
SUPPORT_URL="http://www.raspbian.org/RaspbianForums"
BUG_REPORT_URL="http://www.raspbian.org/RaspbianBugs

However, when I run apt-upgrade apt is failing to get the Release packages for Stretch. If I were to make an assumption it would be this is because Stretch is still in testing (thus not released). Despite my best efforts to read about Raspbian/Debian Packages, I'm failing to get a complete grasp on what they should be when using testing instead of stable.

Here's the originally error when running apt-get update

Ign:1 http://mirrors.cat.pdx.edu/raspbian/raspbian stretch InRelease           
Ign:2 http://mirrordirector.raspbian.org/raspbian stretch InRelease            
Err:3 http://mirrors.cat.pdx.edu/raspbian/raspbian stretch Release             
  Unable to connect to mirrors.cat.pdx.edu:http:

Browsing to the mirror I see that a "Release" folder is present.

I also tried changing stretch to testing to see if that would yeield better results. Yet in this case armf failed as well as jessie packages.

Err:6 http://mirrordirector.raspbian.org/raspbian testing/main armhf Packages
  Unable to connect to mirrordirector.raspbian.org:http:
Ign:5 http://mirrors.cat.pdx.edu/raspbian/raspbian testing/main all Packages
Err:7 http://mirrors.cat.pdx.edu/raspbian/raspbian testing/main armhf Packages
...
  Unable to connect to mirrors.cat.pdx.edu:http:
Err:38 http://archive.raspberrypi.org/debian jessie Release
  Unable to connect to archive.raspberrypi.org:http: [IP: 46.235.227.11 80]

My sources.list currently looks like this:

deb  http://mirrors.cat.pdx.edu/raspbian/raspbian  testing main contrib non-free rpi 
deb  http://mirrordirector.raspbian.org/raspbian   testing main contrib non-free rpi

I'm hoping this is a case where I'm overlooking something basic in how packages works. Any help ya'll can provide would be amazing.

EDIT: Looks like the main problem was an incorrect static IP setup. I resolved it by following this guide. I am still getting a few errors, but I think that may be because I'm using an unreleased versions. Any thoughts on how to correct the following would be great:

W: The repository 'http://archive.raspberrypi.org/debian stretch Release' does not have a Release file.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: Failed to fetch http://archive.raspberrypi.org/debian/dists/stretch/main/binary-armhf/Packages  404  Not Found [IP: 46.235.227.11 80]
E: Some index files failed to download. They have been ignored, or old ones used instead.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.