I just bought a Raspberry Pi 3 Model B with NOOBS microSD Card. I only connected the USB cable for power and the HDMI cable, it keeps rebooting with these errors, like it is stuck in a loop.

/init: line 27: can't create /sys/class/leds/led0/trigger: nonexistent directory
[     1.629060] brcmfmac: brcmf_c_preinit_dcmds: Firmware version = w10: May 27 2016 00:13.30 version (r640327) FWID 01-df77e4a7
[     1.656696] brcmfmac: brcmf_cfg0021_reg_notifier: not a ISO3166 code

If I plug a "microsoft all in one media keyboard" it goes in kernel panic.

  • 1
    Watch the red power led closely while booting or plugging in the keyboard. Does it flicker at all?
    – goldilocks
    Feb 4 '17 at 20:49

I had the same error. One day, I normally shut down my Pi but on the next day I tried to turn it on and the screen went black, and it did not turn on and showed the same error message. I was scared that my SD card got corrupted, but finally, I could resolve the problem:

When the Pi tried to boot, it displayed Hold Shift for Recovery Mode for some seconds. I did so, and then I could edit the config file on the installation screen. It contained a line device_tree=, that I commented out, and then saved and pressed Exit. Then my Pi rebooted and fortunately, it worked again.

I hope it helps.


It looks like your SD card might not have the correct installation or it might be corrupted.

Could you try reformatting your SD card and reinstalling NOOBS?


I solved this by adding boot_delay=3 to config.txt. Causes a 3 second delay in the boot process. Presumably, the SD card need time to start up.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.