2

I have set up and connected with VNC Viewer in the past and it has worked fine.

I have recently changed my Raspberry Pi login password from "raspberry" to something more specific and now when I try to connect the VNC I get an "Authentication Failure" message.

I originally followed these steps to set it up and it worked fine.

http://lifehacker.com/how-to-control-your-raspberry-pi-from-any-computer-usin-1788592777

Does anybody have any idea why this is happening or what I might be doing wrong?

Any help would be greatly appreciated.

3

Use the command vncpasswd (man page).

It appears that you can change the VNC password by way of the VNC Server desktop app. If you can log into the Pi using an actual monitor, then get X running (startx), open the VNC Server app, go to Options, then Users and Permissions, click on Password, and confirm a new password to use.

1

I don't usually use RealVNC which I guess from the link you posted you do.

I use tightvncserver, and the first time you use it you run vncpasswdwhich stores encrypted password in ~.vnc/passwd.

I assume RealVNC is similar.

  • I tried tightvncserver and ended up with the same authentication failure. Do I need to replace the ~.vnc/passwd or delete it? How do you suggest I fix this? – DNavarro Feb 5 '17 at 21:29
  • @DNavarro It won't hurt to delete it, as it should be re-created. You really need to read the RealVNC documentation, although I find it rather convoluted. The other suggestion is to turn VNC off, delete ~.vnc/passwd (or ~.vnc/) and turn VNC on, which will hopefully re-create the password. – Milliways Feb 5 '17 at 23:23
  • DNavarro, I have the same problem. Please can you tell me how you got it to work ? – Simon Dec 5 '17 at 1:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.