1

I am trying so hard, to get this octopi to work. I have the B v1.2 with the 5inch 800*400 pixel. I cannot seem to get the GUI to work. After boot it hangs on Starting NTP Server, I type in Putty Startx and it spits out this:

X.Org X Server 1.17.2
Release Date: 2015-06-16
X Protocol Version 11, Revision 0
Build Operating System: Linux 3.8.11-2-ARCH armv7l Raspbian
Current Operating System: Linux raspberrypi 4.4.21-v7+ #911 SMP Thu Sep 15 14:22:38 BST 2016 armv7l
Kernel command line: 8250.nr_uarts=0 dma.dmachans=0x7f35 bcm2708_fb.fbwidth=640 bcm2708_fb.fbheight=480 bcm2709.boardrev=0xa02082 bcm2709.serial=0xcd6ed80f smsc95xx.macaddr=B8:27:EB:6E:D8:0F bcm2708_fb.fbswap=1 bcm2709.uart_clock=48000000 vc_mem.mem_base=0x3dc00000 vc_mem.mem_size=0x3f000000  dwc_otg.lpm_enable=0 console=ttyS0,115200 console=tty1 root=/dev/mmcblk0p2 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait quiet splash plymouth.ignore-serial-consoles fbcon=map:10 fbcon=font:VGA8x8 consoleblank=0 quiet
Build Date: 11 January 2016  01:32:44PM
xorg-server 2:1.17.2-1+rpi1 (http://www.debian.org/support)
Current version of pixman: 0.33.3
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.1.log", Time: Tue Feb  7 00:02:23 2017
(==) Using config directory: "/etc/X11/xorg.conf.d"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
modprobe: FATAL: Module g2d_23 not found.

Is it because I do not have the screen configured or what. I cannot find anywhere the right settings to even get into the GUI first let alone get octopi to work.

Any help is appreciated.

Thanks.

  • Could you be clearer on exactly what it is you are doing? What is an octopi? What is the model of the screen you are using (with a link perhaps)? Does a normal monitor work through the HDMI output? What OS are you running? – Deleuze Feb 7 '17 at 9:36
0
mv /usr/share/X11/xorg.conf.d/99-fbturbo.conf ~ 

solved it for me (Or you can just delete 99-fbturbo.conf)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.