I am using KODI on a Raspberry Pi 2 B (openelec) with my Panasonic Viera plasma screen model TH-42PX81FV.

I found, that not all the button presses from the remote are actually reported over the HDMI cable to the computer. Here is what my remote looks like:

main remote

However I am trying to get the bottoms ones to work, those:

bottom remote

There are some well known tricks to get thos buttons to work from the kodi FAQ, and some other source on the net:

However my remote is not exactly the same as the one depicted over there. After trying multiple times, it still does not work. I even powered off the tv with Raspberry plugged in, I can only get the top buttons to work.

How would one get the media control buttons on bottom of the remote to work on Panasonic TH-42PX81FV ?

1 Answer 1


I have an identical problem at home and, unfortunately, we're both out of luck. Not all buttons on all remotes produce a corresponding HDMI CEC signal at the TV. I diagnosed my issue using the instructions given in this Kodi forum thread by user misa on 2013-08-25 10:12:

Determine what button you would like to use. Find out the "keyname of that button" by this.

1/------Enable debug logging---

SYstem --> Settings --> System --> Debugging --> Check Enable debug logging

2/------SSH into your Pi and type in this command--- Code:

tail -F /storage/.xbmc/temp/xbmc.log | grep OnKey

Now any button you press you should get some output. This is the Output when I press my green button:

17:04:30 T:3041878016 DEBUG: OnKey: ctrl-alt-a (5f041) pressed, action is

I get expected responses from all the buttons on my remote that already worked, but no responses whatsoever from the buttons that didn't. What this means is that those buttons do not cause the TV to transmit an HDMI CEC signal to the Pi, which means that they're forever useless for the purposes of controlling Kodi. The only way to add them would be to reprogram the TV's firmware, which is only realistically achievable by the manufacturer.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.