2

I'm trying to set up bluetooth on my pi3. I've tried following a few guides (starting from a fresh install each time), but each time I hit the exact same problem.

Following this guide, I've done the following:

sudo apt-get update
sudo apt-get upgrade
sudo apt-get install pulseaudio-module-bluetooth bluez-tools
sudo gpasswd -a xbian pulse
sudo gpasswd -a xbian lp
sudo gpasswd -a pulse lp
sudo gpasswd -a xbian audio
sudo gpasswd -a pulse audio
sudo sh -c "echo 'extra-arguments = --exit-idle-time=-1 --log-target=syslog' >> /etc/pulse/client.conf"
sudo hciconfig hci0 up
sudo hciconfig hci0 class 0x200420
sudo reboot

However, after a reboot, if I run hciconfig hci0 class it shows a class of 0x000000

If I then use bluetoothctl to set discoverable on and pair to a device, I get told the device has switched to class 0x4

Any ideas what the heck I'm doing wrong?

(bluez is version 5.24, raspbian is jessie/pixel January release)

  • I'm having a similar problem. In my case, I'm trying to turn my Pi into a Bluetooth speaker, so I defined Class = 0x20041C in /etc/bluetooth/main.conf. It worked the first time, but since rebooting it now uses class 0x00041C (same kind of device, but it drops the audio service class and my phone no longer connects). Tried overruling with hciconfig, but it doesn't work :/ – rensa Aug 12 '17 at 6:45
  • Looking a bit closer, hciconfig sticks until I use discoverable on in bluetoothctl. – rensa Aug 12 '17 at 6:50
  • Or maybe not . Tried pairing without turning discovery on and connection still failed (and class reverted when I tried). No idea what's going on. – rensa Aug 12 '17 at 6:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.