0

world\n

I have been desperately trying to set up a pi Zero as a dongle computer, in order to ultimately try to install poison tap on it. There are quite numerous howtos on the web, like the one you can hit on adafruit. I managed to get the Zero booting up with Jessie, I set up the config files to make it act as ans RNDIS adapter. Now, when it's booted I can see from the computer on which the Zero was plugged in

lsusb

Bus 003 Device 091: ID 0525:a4a2 Netchip Technology, Inc. Linux-USB Ethernet/RNDIS Gadget

ifconfig usb0

usb0: flags=4163 mtu 1500 ether 6e:f2:1f:89:5d:09 txqueuelen 1000 (Ethernet) RX packets 45 bytes 9888 (9.6 KiB) RX errors 0 dropped 0 overruns 0 frame 0 TX packets 101 bytes 17646 (17.2 KiB) TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0 * as you can see, no IP address * but I have this showing up

arp-scan 192.168.1.0/24

192.168.1.93 e8:4e:06:0d:79:f2 EDUP INTERNATIONAL (HK) CO., LTD

*** it has an IP assigned, a different MAC address, but the manufacturer is one of the Zero manufacturers ... and it comes in when I plug the Zero in and goes away when I plug it out ...

I have tried to ssh on this address, but I am constantly denied access :

ssh pi@192.168.1.93

pi@192.168.1.93's password: Permission denied, please try again.

... I am willing to take any suggestion into consideration, thanks in advance for your time

  • It's fine to play with such toys, but never use it to do illegal things. I was twice convocated by the french police for far less than that ;) – Technico.top Nov 8 '17 at 23:52
1

Did anybody succeed in a Pi Zero dongle setup?

Yes, many of us. In practice it works flawlessly on macOS and Windows, while Linux is more problematic. I use this on Ubuntu 16.04 but you'll find a good number of unanswered Linux + g_ether questions here on Pi Exchange.

as you can see, no IP address * but I have this showing up: arp-scan 192.168.1.0/24

If no IP address was assigned on your host RNDIS interface then the Pi Zero likewise never received an IP address. Your arp-scan is probably finding a different host on your local network.

On Ubuntu, typically an IP address does not get assigned out of the box. The next step is usually to click the NetworkManager GUI tray (top right), edit Connections to revise Wired Connection 3 (or whatever it is numbered), and set it to Link-Local Only in the IPv4 settings.

After a few seconds, if this gets it to say Connected you then have hope of successfully pinging raspberrypi.local

If it appears to connect but you still cannot find the Pi Zero on the network by name, you can next troubleshoot (e.g. run ifconfig) on the Pi itself. Even if you don't have WiFi working or a UART-to-USB cable, you can still get gadget serial running at the same time as RNDIS and connect via screen or minicom.

Load g_multi instead of g_ether via /etc/modules and add:

options g_multi file=/dev/mmcblk0p1

to /etc/modprobe.d/multigadget.conf. (Use a valid partition to ensure the mass storage gadget is happy. More details in this gist.)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.