3

Ok, Ive read the other ssh related questions, but cannot seem to find one that matches my exact issue.

Having just built a Pi3 with XBMC and Kodi17.1 (NOOBS installation of XBMC), I tried to ssh into the box to create some custom scripts.

I enabled ssh when the box was built but cannot for any reason log into the Pi remotely. The Pi is assigned a static IP on my home network and is connected via LAN cable to a local switch.

Ive tried from my Linux Desktop and also from my Windows laptop (using Putty).

On both systems I can ping the Pi box, and when using SSH, I am presented with the login prompt (so I can assume the ssh daemon is running), but it doesnt like the username / password.

Ive been attempting to use UID - pi and PASS - raspberry but this has not resulted in a successful connection.

Has anyone tried / succeeded in doing this ?

Should I just abandon the XBMC install and go for a full Raspbian install and run Kodi from cron ?

Help !!...

  • I notice you've buried your solution to this somewhat. If you (or someone else) were to write that up as an answer, there's a good chance of picking up some points from it. – goobering Feb 14 '17 at 14:26
  • Will do. I didnt want to answer my own question having only asked it a few hours ago, but as I have the solution, Ill do a quick writeup Thanks – Jason Vaughan Feb 14 '17 at 14:55
3

When trying to connect to the OSMC Media center (installed from the NOOBS installer), remember that it is OSMC and not XBMC. To remote connect via ssh you need to use the credentials osmc/osmc and NOT the default pi/raspberry login as is so widely documented

0

I think it sounds plausible that you've installed OpenELEC, as opposed to vanilla Kodi. OpenELEC uses a different username and password. From the OpenELEC FAQ pages:

What is the SSH login?

Currently the login into OpenELEC has fixed settings.

 Login: root
 Password: openelec

Note that these values are case-sensitive.
  • Thankyou for the suggestion. Tried the openelec credentials but that doesnt work either :( – Jason Vaughan Feb 14 '17 at 13:26
-1

Make sure that you have your ssh daemon enabled at settings.

For example, for OpenELEC you will find the configuration of the daemon under Settings/Services:

enter image description here

For Raspbmc, you will find it under Programs/Raspbmc Settings/System Configuration:

enter image description here

  • I'd be right on board with this answer if it weren't for the SSH login that's being presented: '...when using SSH, I am presented with the login prompt...'. The daemon's definitely running, but the login appears to be wrong. – goobering Feb 14 '17 at 11:32
  • Just double checked, OSMC, Installed Feb 2017, ssh Server definatly running. Was able to log into the server using the web too .. <IP Address>:8080 – Jason Vaughan Feb 14 '17 at 13:49
  • Updated to add, Ive just tried osmc/osmc and it works !!! ... Sorry guys, New to Pi – Jason Vaughan Feb 14 '17 at 13:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.