1

I installed upstart and reboot Raspberry Pi 2 with Raspbian Jessie PIXEL. However, the system has not booted succesfully. The error is:

Mount failed for selinuxfs on /sys/fs/selinux: No such file or directory

Once I get the error, I clear my SD card and reformat with Jessie and it worked. However when I installed upstart and reboot, same error is appearing. There is no hardware corruption because the system works well without the upstart installation.

1

I got the answer from another forum, hope it will be helpful for you. Main idea of the post is that you should use systemd instead of upstart.The description given below is about recovering steps for a person who have installed upstart in his/her raspberry pi.I do not check the solution personally because I changed my approach.Here is the solution:

The selinux fs mount problem which stops the booting process is related to installing Upstart. Its a Linux bug which permeates lots Linux flavours from Debian, Ubuntu to Redhat.

To fix it you can do the following steps: If you only have one raspberrypi: (1)Install the Pi OS onto a fresh new MicroSD card and do a full update on it apt-get update apt-get dist-upgrade (reboot) rpi-update (reboot) apt-get upgrade

(2)install a USB card reader into the Pi USB sockets and install your "broken" pi MicroSD card into it.

(3)Create a directory called anything you like eg mkdir /brokensystem

(4)Mount your broken system MicroSD root partition onto /brokensystem

The command is mount -t ext4 /dev/sbNM /brokensystem where N is the SD card letter assigned when you inserted it and M is the root partition typically /dev/sdb5, so it might be mount -t ext4 /dev/sdb7 /brokensystem you use the command tail /var/log/messages when you insert the card to find it Sometimes the disk might get mounted for you, the /var/log/messages will tell you.

(5)you now need to mount the old /boot partition underneath the broken system partition mounted above Try mount /dev/sb6 /brokensystem/boot

(6)Once you have mounted your old disk under /brokensystem you can try this

Optional step: overwrite the boot files on the broken system cp -R /boot/* /brokensystem/boot

(You can try the boot overwrite step a second time around if it won't boot after the chroot commands below)

chroot /brokensystem apt-get remove upstart It may complain about missing filesystems etc, but will remove upstart anyway.

shut down the system with init 0 If this "init 0" fails (highly likley) wait a few seconds and then pull out the power

Boot your pi from the originally broken microSD

If it boots... full update it as step (1) above, If it doesn't boot repeat as above but copy the /boot files in the optional step above as well.

This should remove the faulty upstart configuration which "bricks" the Pi.

Do not use Upstart again, use systemd as is recommended, systemd is the way forward, upstart is history.

Hope this helps

Thank peterfarrow to his valuable post

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.