I was using VNC from RealVNC to access my Raspberry Pi 3B. However, the session suddenly stopped, and I get the following error message:

License Issue

However, according to the RealVNC website, I should have a free license for noncommercial use. How do I fix this issue?

  • Any particular reason you're not using x11vnc?
    – bye
    Feb 16, 2017 at 10:40
  • @DrEval RealVNC Server comes bundled with Raspbian, and it's much faster and more usable than x11vnc
    – scruss
    Feb 21, 2017 at 23:09
  • @DrEval Also, you have the ability to cloud connect which you can do outside your local network
    – Human
    Feb 22, 2017 at 1:13
  • @scruss I struggled to get RealVNC to let me connect to the existing session; I wanted to control the current screen, not a new one.
    – bye
    Feb 22, 2017 at 10:31
  • maybe best to ask your own question if this problem persists @DrEval. I installed it with apt, and it's given me access to my main session from the start.
    – scruss
    Feb 22, 2017 at 19:03

3 Answers 3


A new version of RealVNC Server was made available in the repositories yesterday. If you have recently updated your packages and installed this new version, then you will need to restart any running VNC server instances.

It's probably easiest to simply reboot if you can, but if not you can restart the servers.

If you're using the service mode server (i.e. the one that lets you connect to the console session), do:

sudo systemctl restart vncserver-x11-serviced

For virtual mode servers (started via the "vncserver" command), you will need to shutdown the virtual session and restart it. Do:

vncserver -kill DISPLAY

Where DISPLAY is the display number (probably :1 if you have only one virtual mode server running).

and restart the server as normal with the "vncserver" command.


I had no end of trouble with RealVNC. It was all fully licenced (personal), updated, and correctly install but PAM Unix login always failed leading to blacklisting. VNC password authentication worked but I ended up with a postage stamp sized screen. Disable with

systemctl disable vncserver-x11-serviced

and install TightVNCserver as above and use any VNC viewer and it just works. I'm sure with an Enterprise service-level agreement it would be wonderful but it shouldn't have been used for the Raspberry Pi.

  • This page might be of some help: realvnc.com/en/connect/docs/raspberry-pi.html You can set the screen resolution from the Raspberry Pi configuration app, the default is very low if you don't have a HDMI monitor connected since this is the resolution used by the composite TV output. Mar 30, 2018 at 8:28

I got stuck with the same problem on a Pi 2 running Jessie.

What finally worked for me is:

sudo apt-get install tightvncserver. 

It cannot un-install realVNC, but disables it partly. After that I can use vncserver as normal:

-geometry 1920x1080 i.s.o. -randr=1920x1080)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.