0

A few days ago I started to work on a Raspberry pi - POWERLINK project, I found out that an Ubuntu based system is best for this. So I tried to install the Ubuntu Mate 16.04 OS, and I got stuck on a problem.

After flashing my 16 GB Sd card with the image in Windows 7 and inserting It into the Pi, I saw only the "Rainbow screen" and the green LED flashes 8 times (4 short blinks and 4 fast blinks in a row), so I started to change the confing file as It was listed in previous articles (change boot delay etc...) and nothing helped.

I have tried these things:

  1. change the boot_delay=0 in config.txt to boot_delay=1 --> Nothing happened.

  2. Copy the kernel.img and kernel7.img from Raspbian OS --> Nothing happened.

  3. Install an older version of Ubuntu Mate 15.04 or 15.10 --> Nothing happened.

  4. Install Snappy Ubuntu Core --> Another Rainbow screen.

  5. Under Raspbian I tried to update the firmware via console : sudo apt-get update; sudo apt-get upgrade;
    sudo rpi-update;

Yesterday I tried to install Ubuntu Mate through Noobs installer and finally the installation was finished, but ... there is always a but... After installation and going through the rainbow screen and "recovery" screen I got stuck on a black screen and the LED is again blinking 8 times like I have mentioned before. I have tried several methods which were listen on forums, because everyone was decribing that the "Black" screen is because there is some HDMI problem. So I started changing the config file again, but still nothing happened.

I have tried these things:

1: Uncomment hdmi_safe=1 --> nothing happened.

2: Change hdmi_drive=2 to #hdmi_drive=2, because I am using a HDMI to DVI cable --> nothing happened.

3: Change the hdmi_drive=2 to hdmi_drive=1 --> nothing happened

I am totally ruined because I really need to start the implementation of the POWERLINK communication protocol and without this I got a serious problem.

Please If somebody got a same experience or have a solution then please contact me

Thanks.

  • Is this useful? – goobering Feb 16 '17 at 13:56
  • Thanks for your reply, but I have already tried all these tricks, but nothing helped ... Everything works when I am installing Raspbian - no booting problem, no rainbow or black screen. Just other OS is doing this. – Patrik_SVK Feb 16 '17 at 14:17
  • OK. In order to get a useful answer, you're going to have to edit your question to explicitly list out the things you've already tried and what, if any, errors you encountered along the way. There's no sense in retreading ground you've already covered. – goobering Feb 16 '17 at 14:28
  • Ok,thank you for your suggestion. I have edited my question. Now you can see all the things I have done. I think that there is some problem with the SDram recognisation, because I got 8 blinks, but I don´t know what to do with It :( – Patrik_SVK Feb 16 '17 at 14:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.