I have a Raspberry Pi 3. 32 GB edition. The wireless feature was working fine...now it is not. It appears to be connected to the wireless network at work, but typing in a URL results in no result. Also, how do I turn off the wireless feature? Eventually, I will not need wireless capability.

  • There are several options on disabling WiFi on the Pi 3 here. In order to diagnose your problem you're going to have to edit some more information into your question (don't use comments) - can you ping other devices on your network, can you ping external websites, can you ping the DNS servers listed in /etc/resolv.conf? – goobering Feb 16 '17 at 14:37
  • 1
    Please edit your question and include the output of ifconfig, also include the contents of /etc/network/interfaces and /etc/wpa_supplicant/wpa_supplicant.conf. – Steve Robillard Feb 16 '17 at 19:32

Did you edit any static IP configurations that might be wrong and could be the problem?

To disable Wi-Fi you can edit the file /etc/modprobe.d/raspi-blacklist.conf by adding the following lines:

blacklist brcmfmac
blacklist brcmutil

Hope this helps.

  • Hi thanks very much the blacklist information helped – Gerald Kimmich Feb 27 '17 at 14:52

Your Answer

 
discard

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.