I am having trouble getting a USB Camera to work with a Raspberry Pi 3 Model B. I cannot get /dev/video0 to be created. I have run sudo modprobe bcm2835-v4l2 and I can see bcm2835-v4l2 when I run lsmod but there is still no /dev/video0. Where am I going wrong?


  • What make / model of Camera is it?
    – tobyd
    Feb 17, 2017 at 12:33
  • It is a IDS uEye XC.
    – eurotech
    Feb 17, 2017 at 12:35
  • Maybe check this link out - looks like IDS have a driver available for the armv7. stackoverflow.com/questions/16883611/… i'd would summise the driver is not in the kernel hence not populating the device node. The Pdf on the link in the SO answer details the steps on a Pi so i think this might be a good place to start.
    – tobyd
    Feb 17, 2017 at 12:39
  • I have already downloaded the driver and unpacked it successfully. This is probably a dumb question as I am new to Linux but how do I check and see if it is in the Kernel? I appreciate the help
    – eurotech
    Feb 17, 2017 at 12:45
  • By the looks of it, you have to run up a utility (page 5 of the IDS embedded instructions pdf) which gets it all going. I'm not too sure what to expect from this though. Once you've run the setup script as root (its not clear if this is sudo or actually as root sudo su) I'd guess it all becomes clear ( ish :) ). Once installed you can check lsmod to see if an IDS driver has appeared, also lsusb to check what the OS thinks of the usb devices in the system.
    – tobyd
    Feb 17, 2017 at 12:53


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.