2

I've probably mess up my python installation. For using ssl with python I've try to install paramiko:

sudo apt-get install python-pip
sudo pip install paramiko

I tought with sudo pip install paramiko, I install it correctly for the whole system. On a ubuntu 16.4 machine, this was successfully, but perhaps, on a raspberry it was not a good idea? The install fails and I additionally install

sudo apt-get install build-essential libssl-dev libffi-dev python-dev

After that, I installed separately sudo pip install cryptography

It seems, that this was successfully, but now I got in many cases this error

pip --version                                                   

Traceback (most recent call last): File "/usr/bin/pip", line 5, in <module> from pkg_resources import load_entry_point File "/usr/local/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 70, in <module> import packaging.version ImportError: No module named packaging.version

How can I fix this?

Python 2.7.9/ Raspbian GNU/Linux 8

Thanks for help

3

After uninstall pip with

sudo apt-get purge python-pip

and install the newest version without apt

wget https://bootstrap.pypa.io/get-pip.py
sudo python get-pip.py

and reinstalling paramiko, it seems all OK.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.