1

In the latest version of Raspbian (kernel 4.4), any file I stream through youtube-dl to omxplayer or mplayer using the 3.5mm headphone jack works perfectly.

However, in Firefox when I go to any site, it will play the video fine but the only sound you get is a loud static hissing sound regardless of whether you use the 3.5mm or HDMI audio output.

This happens on sites that use Flash like Youtube and sites that don't like Putlocker which uses jwplayer.

How can I fix this?

EDIT: If I stream media through Kodi this issue disappears. However, I believe Kodi uses Omxplayer.

EDIT2: I installed chromium-browser and it works perfectly on youtube and other sites with the audio and the video, I believe its a firefox issue but I am still unsure what is causing it.

1

I found the solution:

sudo apt-get install alsa-utils
sudo apt-get install mpg321
sudo apt-get install lame
sudo modprobe snd-bcm2835

Enabling Audio Output

By default, the RPi audio output is set to automatically select the digital HDMI interface if its being used, otherwise the analog audio output. You can force it to use a specific interface via the sound mixer controls. amixer allows command-line control of the mixer for the ALSA driver.

You can force the RPi to use a specific interface using the command amixer cset numid=3 N where the N parameter means the following: 0=auto, 1=analog, 2=hdmi. Therefore, to force the Raspberry Pi to use the analog output:

amixer cset numid=3 0

also firefox esr -> about:config

media.mediasource.mp4.enabled false
media.mp4.enabled false

 

  • Disabling mp4 in the firefox config did it for me. Firefox made a fail over to webm which played without issues. So sometimes it's not about fixing the issue, it's about mitigating it. – DBX12 May 23 '18 at 17:07
0

I have started using chromium-browser which is the one the Foundation supports now. I believe the issue is hardware acceleration. Audio and video work fine in chromium.

One might be able to install h264ify addon in firefox to fix this issue but I have not tried it and cannot verify if it works.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.