1

I have a project setup that allows for a car installation of an Audio Receiver

Audio Receiver Code

I currently have Kodi setup the autorun on boot. Around 10+ minutes the Kodi screen becomes transparent with a transparent CLI (also transparent) overlayed on top. Audio still plays fine and you can navigate Kodi with the remote, but it pretty much ruins the reason for having Kodi active.

I have tried using setterm -powerdown 0 to no avail. After plenty of research I am still at a loss as to why this is happening.

I am using the Raspbian Jessie update of 1/11/17

  • Looks fairly involved. Have you checked Kodi's logs to see if there's anything out of the ordinary happening? Does the CLI show any indication as to why it's been launched? – goobering Feb 22 '17 at 19:39
  • It pops up with the typical raspberry pi login. The pi is just sitting idle and shouldn't need any login prompt. Do you know of where the log files are for kodi? – Brett Reinhard Feb 22 '17 at 19:50
  • Take a look at the link in my first comment. – goobering Feb 22 '17 at 19:50
  • Your question has "raspbian" tagged to it. What version are you using? – MadMike Feb 22 '17 at 20:15
  • @MadMike update, 1/11/17 Raspbian Jessie – Brett Reinhard Feb 22 '17 at 20:22
1

A simple fix of adding consoleblank=0 to the /boot/cmdline.txt file fixes the transparent CLI from overlaying on top of kodi. I believe you can disable the faded kodi screen somewhere inside kodi, most likely power saving or power management.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.