0

Rpi-update fails due to some certificates errors:

rpi-update 
 *** Raspberry Pi firmware updater by Hexxeh, enhanced by AndrewS and Dom
 *** Performing self-update
 *** Relaunching after update
 *** Raspberry Pi firmware updater by Hexxeh, enhanced by AndrewS and Dom
 *** No hash received from github: https://api.github.com/repos/Hexxeh/rpi-firmware/git/refs/heads/master
curl: (60) SSL certificate problem: certificate is not yet valid
More details here: http://curl.haxx.se/docs/sslcerts.html

curl performs SSL certificate verification by default, using a "bundle"
 of Certificate Authority (CA) public keys (CA certs). If the default
 bundle file isn't adequate, you can specify an alternate file
 using the --cacert option.
If this HTTPS server uses a certificate signed by a CA represented in
 the bundle, the certificate verification probably failed due to a
 problem with the certificate (it might be expired, or the name might
 not match the domain name in the URL).
If you'd like to turn off curl's verification of the certificate, use
 the -k (or --insecure) option.

When I try to launch with -k option I get following error:

rpi-update  -k
 *** Raspberry Pi firmware updater by Hexxeh, enhanced by AndrewS and Dom
 *** Performing self-update
 *** Relaunching after update
 *** Raspberry Pi firmware updater by Hexxeh, enhanced by AndrewS and Dom
Invalid git hash specified

My raspian is fully updated (aptitude update ; aptitude upgrade)

  • The message is printed by curl, not rpi-update. The -k option is a curl option. It has no meaning to rpi-update – joan Feb 22 '17 at 22:28
  • Is there a reason why you're trying to run rpi-update? – ElefantPhace Feb 22 '17 at 23:23
  • > "In normal circumstances there is NEVER a need to run rpi-update as it always gets you to the leading edge firmware and kernel and because that may be a testing version it could leave your RPi unbootable". raspberrypi.org/forums/viewtopic.php?p=916911#p916911 Even the rpi-update documentation now warns "Even on Raspbian you should only use this with a good reason. This gets you the latest bleeding edge kernel/firmware." – Milliways Feb 23 '17 at 4:32
  • 1
    What's the output of date when you do this? – goldilocks Feb 23 '17 at 8:50
0

Check system time. SSL(encrypted connections) will not work unless the correct time is set.

Use below command to set system time sudo date -s "29 May 2019 11:58:00"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.