1

I tried to connect a Hanns­G HT225HPB 21.5'' touchscreen or an Elo ET1502L to my Raspberry Pi 3. Both connect via HDMI and USB for touch.

Both seem to work at first glance but are not really usable. If i touch a point on the screen the position of the touch is recognized just fine but I can't klick. It seems completely random how my touch is recognized. Sometimes its a rightclick, sometimes a mouse drag, sometimes a leftclick sometimes it just moves the cursor.

These problmes occur with raspian jessie and ubuntu mate for the pi but both screens work just fine on a ubuntu desktop pc. I assume it's a problem with kernel drivers but i can't figure out a way to fix it.

  • Exactly the same problem with a fresh install of Raspbian (Jessie) on a RPi3B with a 10"1 touch screen. Can't click correctly; the pointer seems to do drag & drop or other stuffs, but not click the normal way. – Gug Mar 6 '17 at 15:48
2

I had the same problem with Jessie & a Pi3. A firmware update of the monitor solved my problem. For the update you need a windows pc. After the update the touch (single click) works fine.

At the support website of Hannspree you can download the firmware: http://www.hannspree.eu/en/faq-touch-monitor#faqa3-2

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.