1
  • I've download the file Raspbian jessie with pixel.img.
  • I wrote the .img-file with Win32DiskImager to an SD-card.
  • I wrote an IP address in the cmdline.txt file (ip=169.254.10.1).
  • I've put the SD-card in the Raspberry Pi.
  • I put the network-cable in the Raspberry Pi.
  • I connected the power to the Raspberry Pi and I opened PuTTY.

I wrote 169.254.10.1 in the "host name" and then I clicked "Open".

But I get the error:

PuTTY (Inactive)

Is there anyone who can help me and knows what the problem is?

  • 1
    Welcome to Raspberry Pi. Please edit your question and add: How did you write the .img to the sd-card? After you put the sd-card into the Raspberry Pi, (yeah, I know this may sound like a silly question) did you connect the Raspberry Pi to the USB-Adapter to boot it up? Are using some How-To or Tutorial to do this? Which one? – MadMike Feb 24 '17 at 9:58
  • 1
    'Putty (inactive)' isn't an error message. It's a status message, letting you know that Putty currently isn't connected to anything. Before you get to the point of seeing the 'inactive' message you should see a popup window with the title 'PuTTY Fatal Error' which includes the error message, which is the bit you'll need to edit into your question. – goobering Feb 24 '17 at 14:10
1

169.254.10.1 is a Link-local address.

While you can use a Link-local address on a single point-to-point link, it only has limited support for networking.

Even if Putty would ssh over a Link-local address, unless you have enabled ssh you won't be able to connect.

169.254.10.1 would NOT be the "host name".

This is a partial answer to "what the problem is". Actually getting your system to work is more difficult; you would be better plugging the Pi into your router, and using the standard settings.

0

In the newest Jessie Image ssh is disabled by default. You'have to enable ssh before you use Putty.

To enable ssh, create a empty file named ssh in the SD card (no extension required).

0

You should give your device a class A, B or C IP Address rather than what you have.

For example a common class C address would be 192.168.1.10 with a subnet mask of 255.255.255.0

The device you are initiating the connection from needs to have an IP Address in the same range.

As previously stated, can you not plug the Pi into your router and get an address via DHCP automatically? The IP of the Pi should display on the screen if you have one connected via HDMI.

0

run sudo raspi-config select option 5 "Interfacing options" and be sure "P2 SSh" is set to enabled so that sshd starts when the pi boots.

be sure you have a valid IP address. check ifconfig for your IP. if the session from putty is working you will be prompted for a username and password.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.