3

I can't get any audio from mpc. I can listen to sounds from websites.

Screenshot from my Console

I think I might need to edit the etc/mpd.conf

This might help as well: enter image description here

  • Your image links aren't working. – Jacobm001 Feb 28 '17 at 17:46
  • I opened the question in another browser without being signed in and I can see them. Did you fix it? Are you still not seeing the pictures? – PalimPalim Feb 28 '17 at 18:00
  • No, but I got an error message this time. Looks like whichever load balancer my part of the world sees for imgur is over capacity. – Jacobm001 Feb 28 '17 at 18:01
  • Please don't use images for text output. Instead paste the text direct into the question. – Ingo Mar 10 '19 at 19:26
1

You may use the ALSA output to use the stereo jack

/etc/mpd.conf

audio_output {
        type            "alsa"
        name            "My ALSA Device"
}

Alternatively if you want to listen to music from your Android or IPhone or tablet you can setup the Streaming output. Then standard Apps can listen to your music from RPI by standard stream:

/etc/mpd.conf

audio_output {
       type            "httpd"
       name            "My HTTP Stream"
       encoder         "vorbis"                # optional, vorbis or lame
       port            "8000"
       bind_to_address "192.168.1.10"          # optional, IPv4 or IPv6
       quality         "5.0"                   # do not define if bitrate is defined
       bitrate         "128"                   # do not define if quality is defined
       format          "44100:16:1"
       max_clients     "0"                     # optional 0=no limit
}

NOTE: you can actually enable both outputs (ALSA + STREAM) at the same time.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.