1

I managed to get my RPi3 running on an old TV with a composite-RCA cable. I have since enabled SSH on Raspbian, and I can access the Pi using my Ubuntu laptop - but only through terminal, as far as I can see.

I'm wondering how I can access the whole desktop, for example, of the Pi on my laptop. In other words, is there a way to access the Pi as if it were my laptop? I'm not sure if this is the same thing as simply running the GUI, or whether this could be done with TightVNC. It seems at least related but I'm new, so not sure.

Thanks very much.

1

Screens cannot be shared with ssh. You need a remote GUI protocol. There are 2 approaches to VNC which is the most popular;

The latest Raspbian images include RealVNC, which can be enabled from raspi-config (or the equivalent GUI menu).

By default this shows the SAME desktop you see on your GUI, BUT requires X11vnc, and in practice requires you use the RealVNC viewer.

You can install tightvncserver which starts VNC independently of GUI display, but lets you independently set screen resolution. This needs to be started manually or with a script, which can be done at boot.

See the links in https://raspberrypi.stackexchange.com/a/56381/8697

  • The RealVNC Server doesn't require x11vnc to be installed. It also provides a virtual mode server which you can start by running "vncserver", in the same way as you would with other VNC variants. – Andrew Wedgbury Mar 1 '17 at 11:36
0

VNC

I wrote a guide for setting up VNC in an answer for a different question. Here it is.


X11 Forwarding

If you just want to use individual graphical applications on your raspberry pi (and not your entire desktop), then you can forward X11 traffic over SSH.

  • On your raspberry pi, edit /etc/ssh/sshd_config and make sure X11Forwarding is set to yes
  • On your laptop, install an X11 server (I use Xming on Windows and XQuartz for Mac)
  • On your laptop, enable X11 Forwarding* and ssh to your raspberry pi

Now, if you try to start a graphical program (say, easytag), it will open a new window on your laptop.

graphical easytag program running on a raspberry pi, but the program window is displayed on the laptop screen


*How to enable X11 Forwarding varies by ssh client program:

  • For the command line ssh, just add -X

  • For PuTTY, check the Enable X11 Forwarding checkbox in Connection > SSH > X11. Also enter 127.0.0.1:0 in the X display location text field.


Troubleshooting

  • If you changed /etc/ssh/sshd_config, reload the ssh daemon using systemctl reload ssh
  • Xming must be installed and running on your laptop in order for X11 Forwarding to function

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.