0

It's weird, I can reach google.com, perform a search and see the results, pull up Gmail, I can go to raspberrypi.org, but anything past that I cannot reach.

In the Terminal I cannot ping google.com. "Network is unreachable" I can ping 127.0.0.1

The kernel IP routing Table returns

Destination   Gateway  Genmask       Flags Metric Ref  Use Iface
192.168.1.0   0.0.0.0  255.255.255.0   U     202   0    0   eth0

I know the default gateway is 192.168.1.254 and have tried adding it to the table but it did not fix the issue. I am able to ping the default gateway and have been issued an IP address.

I've tried changing the interfaces file to read:

iface eth0 inet dhcp

Any help would be appreciated.

  • What's in your /etc/resolv.conf? – John La Rooy Mar 2 '17 at 0:13
  • I think I figured out my issue. I realized that after downloading NOOBS, I failed to unzip the file and just copied over the contents. I think something did not decompress. I wiped the SD card and reloaded the files. Then re-imaged the Raspberry Pi and viola everything works now. – Anthony Bruno Mar 2 '17 at 0:36
  • In that case you should do one of two things, either delete your question or answer your own question. – Steve Robillard Mar 2 '17 at 0:44
0

I re-imaged the RaspberryPi to the default setup. This cleared up the issue.

Since this was a brand new install it seems as if some of the file may have been corrupt on the initial install. It was easier to reimage than to deep troubleshoot.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.