1

I've run into some issues with the new Pi zero W. First I tried to run an image of raspbian from 11-1-17' but that did nothing. Well, it booted but couldn't set up a Wi-Fi network. So I've installed a new image 16-2-17' and then the Wi-Fi worked like I expected.

Later, I updated a Pi 2 and swapped that SD card into the Pi zero W, and everything was working fine.

Then I changed the GPIO ports in some python programming and I got all sorts of errors (and again no Wi-Fi).

brcmfmac: brcmf_sdio_txfail: sdio error, abort command and terminate frame
brcmfmac: brcmf_sdiod_regrw_helper: failed to read data F1@0x0a020, err: -84
brcmfmac: brcmf_sdio_isr: failed backplane access

My first guess is that the onboard Wi-Fi is connected with the TTY GPIO. As I'm using it to read from a dutch smart meter (DSMR4.x), looks like I've got a conflict with the Wi-Fi.

UPDATE:

hunch was correct in the system log:

btuart[431]: Set Controller UART speed to 3000000 bit/s
Device setup complete
Started Configure Bluetooth Modems connected by UART.

So now the question is, how to use the UART/TTY with Bluetooth/Wi-Fi on a PI zero w?

UPDATE2: I tried to disable Bluetooth using the /boot/config.txt adding dtoverlay=pi3-disable-bt but with no success. Bluetooth still gets loaded.

  • I haven't read up on this but it could be a combined wifi/bluetooth module and if the bluetooth aspect of it takes the UART like on the 3...you could try playing with config.txt along those lines (e.g. to disable bluetooth). If you aren't clear on what I'm talking about: raspberrypi.stackexchange.com/q/45570/5538 Also check the latest image for similar device tree related notes (in the boot parition). – goldilocks Mar 2 '17 at 10:07
  • @goldilocks thanks for the reply, i've mistaken the pi 3 for pi 2. the old code was working on a pi2. if the bluetooth/wifi is on the same module and uses the UART would disableing the bluetooth als disable the wifi? – TD_Nijboer Mar 2 '17 at 10:12
  • It doesn't on the 3 -- you can disable the bluetooth to use the UART and still use the wifi. – goldilocks Mar 2 '17 at 10:15
  • I don't have a Pi zero W - I did look at ordering one, but it would have ended up costing the same as a Pi3, so I haven't tried this, but suspect the serial issues are similar to the Pi3. See How-do-i-make-serial-work-on-the-raspberry-pi3 PS I suggest you use a spell checker; this would make it easier to see what you are really asking. – Milliways Mar 2 '17 at 11:27
  • @Milliways well wath i'm really asking is how to disable the bluetooth and/or connect something to gpio port 14 and 15. The link you provided is the same as goldilocks and as my 2nd update states, doesn't work for me. – TD_Nijboer Mar 2 '17 at 12:06
2

Okay I think I fixed it.

First, disable Bluetooth from loading: systemctl disable bluetooth.service

Then, as this answer says, edit the /boot/config.txt and add enable_uart=1 and dtoverlay=pi3-disable-bt

Inside your code you can then refer to the UART as /dev/ttyAMA0

It works now on a fresh install. Moving the SD Card from the Pi2 to the Pi Zero didn't work (even when fully updated)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.