I have encountered a problem which am not suppose to but i inserted my raspberry pi camera in the the camera slot on the raspberry and powered the raspberry pi but didn’t get the window option that shows where to enable camera.

I did the “sudo apt-get update”, and “sudo apt-get upgrade” , and then “sudo raspi-config” in the terminal but still couldn’t see enable the camera option.

I even went to the preference and selected raspberry pi configuration and under interface i enabled the camera but still couldn't get the camera enabled.

The raspberry pi camera shows it is powered when I insert into the camera port which is at the back of raspberry pi but doesn't power on when I insert the raspberry pi camera into the port thats close to the HDMI port.

Please anyone know whats wrong please help me out cheers.

  • Please edit your question to include paragraphs, punctuation, and proper capitalization.
    – Jacobm001
    Commented Mar 3, 2017 at 23:25

4 Answers 4


The camera port is next to the hdmi connector, the other similar looking port is for a display: https://www.raspberrypi.org/learning/getting-started-with-picamera/worksheet/

If your camera has been enabled then the python scripts in the link will get you some pictures or video. If you get a MMAl out of resources error then the ribbon isn't seated right, either on the pi or on the camera.

Have fun!


you might want to try a

~ $ sudo apt-get upgrade

assuming you're using python try

~ $ vim camera.py

from picamera import PiCamera
camera = PiCamera()
print('image captured!')

then run it

~ $ python camera.py

I also faced the same problem. My camera was enabled but while running script it was asking me to enable the camera. Then I found out that it is because of loose camera connections. There are three connection points as shown in figure 1 and figure 2. Mine was loose at the point shown in figure 2.

Figure 1.

Figure 1 Ribbon cable connectors

Figure 2.

Figure 2: Camera to PCB connector

So, to solve your problem please check connections at all three points.

After checking all connections use the following code to check the working of the camera. The camera will show the preview for 5 seconds.

from picamera import PiCamera
from time import sleep
camera = PiCamera()

Seems the latest Raspbian, bookworm, automatically configures the camera by default, so the camera no longer shows up in the interface list. On my Pi Zero W v1.1, it reports the camera is missing with the following:

~ $ vcgencmd get_camera
supported=0 detected=0, libcamera interfaces=0

However, I can see it is connected by running:

~ $ libcamera-still --list-cameras
Available cameras
0 : ov5647 [2592x1944 10-bit GBRG] (/base/soc/i2c0mux/i2c@1/ov5647@36)
    Modes: 'SGBRG10_CSI2P' : 640x480 [58.92 fps - (16, 0)/2560x1920 crop]
                             1296x972 [43.25 fps - (0, 0)/2592x1944 crop]
                             1920x1080 [30.62 fps - (348, 434)/1928x1080 crop]
                             2592x1944 [15.63 fps - (0, 0)/2592x1944 crop]

So no config, just take a pic:

libcamera-still -o snap.jpg

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.