0

My attempt to upgrade OpenElec 7 on my RP2B to LibreElec is not working as expected.

I currently have OpenElec 7 on my RP2B. I followed the instructions to upgrade to LibreElec by

  • downloading the update .tar file
  • copying the tar file into the 'Updates' folder of my SD card
  • rebooting

However, OpenElec seems to be ignoring the update file. I have tries changing the file permissions of the update file, as well as extracting the tar, with no avail.

Reference : https://libreelec.tv/downloads/

UPDATE: I am using berryboot as my boot manager.

  • I have the same problem, but I am trying to update from libreelec 7.0.1 to libreelec 7.0.3 – Diego Mar 4 '17 at 21:42
1

I fixed it. In my case I was using Berryboot. The thing is that Berryboot uses the same kernel for all your OS. I switched to PINN (enhanced version of NOOBS) and it worked ok.

  • I'm not sure who downvoted. I think you're on to something here. I am also using berryboot. I didn't mention it as I didn't think it was relevant. However, I found that Berryboot keeps things in squashfs and files in the /update directory are not always available to OpenElec upon boot. – crafter Mar 10 '17 at 10:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.