0

TLDR: I added a line in the terminal for which applications to open on startup, and now I can't get past the login. Is there a better way to fix this than reinstalling my OS?

I installed Iceweasel on my Pi and wrote the following in the terminal:

sudo nano /etc/xdg/lxsession/LXDE/autostart

and added @iceweasel to the list. Now, on reboot my Pi will give me the login w/ password screen. On entering my login info, the Pi does not continue to my desktop, instead it returns to the login screen. Do I need to re-install Debian or can I edit that line out without loading my desktop? Bonus points if anyone might know what I've done to cause the system to crash. I am using the following guide:

http://www.instructables.com/id/Raspberry-Pi-Wall-Mounted-Google-Calendar/?ALLSTEPS

  • Make sure your .XAuthority file is owned by your user – ElefantPhace Mar 6 '17 at 2:07
0

Not sure this will work but you could try to boot the RPI in safe mode that may help on recovery.

Instructables.com is not a good place to find good tutorial, not because of the content quality (there are good projects and instructions there), but because it doesn't tell you how dated the content has been.

I know for sure that this specific instructable is old because if you are using Jessie, the correct directory for modifying the global autostart is under /LXDE-pi (the /LXDE is "old" location and may exist, but it will be ignored). The /etc/xdg/lxsession/LXDE-pi/autostart is the global autostart file, and works for all users... unless there is a user autostart.

If the user has an autostart file, the global one is ignored and the personal autostart is used. User settings (at ~/.config/lxsession/LXDE/autostart) are applied last and take precedence over global settings. Jessie creates a user's autostart file during the install, so changing settings in the global file no longer have any effect.

This however does not provide any explanation on what went wrong on your configuration, but I think this is the information that you should know, and as you can figure out that your adding to the global settings should not work and ignored.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.