Good day everyone, I was working on my raspberry pi when I suddenly lost my internet connection. I followed this guide last night and everything was working fine, my RaspberryPi was able to connect to the internet without problems.

However, a couple of hours ago, the Rπ can no longer connect to the internet even though I didn't touch the internet settings.

Here are the settings for the Ethernet for the Macbook Pro:

enter image description here

And then I just copied the DHCP from the WiFi one to the Ethernet and it worked last night.

This is the nameserver:

nameserver 192.168.2.1

and the for the network interfaces:

auto eth0 
iface eth0 inet static
address 192.168.2.2
netmask 255.255.255.0
gateway 192.168.2.1

I'm not really sure what suddenly cut the internet connection to my Rπ and I'd be more than happy if someone can point out how I can fix it.

auto eth0 iface eth0 inet static address 192.168.2.2 netmask 255.255.255.0 gateway 192.168.2.1

  • Unless you are using an old Pi and a 2½ year old version of Raspbian, following this link seems futile. See How do I set up networking/WiFi/Static IP If you want to use ICS on the Mac, the Pi would work out of the box, with no fiddling. – Milliways Mar 7 '17 at 6:43
  • @Milliways I'm using a RaspberryPi 2 Model B V1.1 but I got the latest NOOBS OS. – Razgriz Mar 7 '17 at 6:47
  • And I'm connected to the Macbook Pro and not the Router. – Razgriz Mar 7 '17 at 6:54

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.