0

So I have just made and installed opencv3.2 for python3.

I went to import the package, and upon import, I am at 75% cpu consumption without processing anything or even grabbing a frame.

Does anyone know of why this would be? I installed OpenCV3.0 on my father's raspberry pi3 a while back and don't remember this being the case.

Thanks in advance!

  • What operating system are you using? Exactly what commands did you run? – Bex Mar 8 '17 at 6:48
  • Raspbian. I start up the python3.4 terminal and enter "import cv2". The cpu usage shopts up to 75%. I am using the newest version of Raspbian, the one with pixel. – user63347 Mar 8 '17 at 13:30
1

I had the same issue, where just by importing OpenCv in Python casts my CPU usage to 75% without using any other line of code.

An engineer in the Official Raspberry Pi forum provided a link to a discussion with the possible solution in: https://github.com/numpy/numpy/issues/6237

The solution worked perfectly for me and for the others having the same issue on that forum. Hope it helps:

$ sudo apt-get install libatlas3-base

$ sudo update-alternatives --config libblas.so.3

choose the libatlas option

$ sudo update-alternatives --config liblapack.so.3

choose the libatlas option

$ sudo aptitude purge libopenblas-{base,dev}

  • Thank you this worked perfectly. I crossposted this on Stack Overflow; hopefully this is seen by others and helps them. Thanks a lot. Is it known why this is happening? This method may be slightly destructive for other users (it made me remove a whole host of packages on my Pi3 when I did this, any way to preserve them?) – user63347 Mar 19 '17 at 2:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy