1

why do you think the options under A6 are not showed? I need to enable the I2C options to use a LCD. I DON'T understand what is happening.enter image description here

2
  • 2
    have you tried it from the preferences menu in the desktop? Mar 9, 2017 at 1:51
  • i have totally forgot about that. Under raspi-config:advanced options:i2c is there only the option to enable the i2c or is there something else? I will tell you if the lcd works in a few minuts Mar 9, 2017 at 2:18

4 Answers 4

1

EDIT: I was completely wrong. This answer is correct.

You might be using an older version of raspi-config or something similar. Try selecting the "update" option and see if it shows the I2C enable option now. If not, the desktop application "Raspberry Pi Configuration" should definitely have it.

2
  • I don't understand why this is marked as the answer. He was looking in the wrong menu.
    – 88weighed
    Oct 6, 2017 at 19:26
  • @88weighed I agree, but I can't delete my answer now. I'll edit to include a link to one of the other answers.
    – anonymoose
    Oct 6, 2017 at 20:50
4

Take a look under option 5, "Interfacing Options" A gif showing the raspi-config tool being used to enable I2C

3

I have the same options to choose from in Advanced Settings as in your picture, but in 5 Interfacing Options I found the option P5 I2C

Maybe that helps someone.

1
  • This is the correct answer.
    – 88weighed
    Oct 6, 2017 at 19:26
2

To enable I2C you need to do three things.

  1. add the line dtparam=i2c_arm=on to /boot/config.txt
  2. add the line i2c-dev to /etc/modules
  3. reboot

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.