Yesterday, my Raspberry Pi 3 didn't boot, and the problem was in the micro SD slot. If I just plug power, only the red LED lights up and stays solid. But if I also press on the card, the Pi boots and all goes well. So, there was no contact with the SD card, as the cover didn't hold it good enough. As a hot fix, I used a little pin to stick it there, and it worked.

But the pin doesn't look good, so I decided to find out what's the cause of that. The problem, as I thought, was in one of soldering pads falling off the board (the one near the J9 label). So, I soldered it:

Bad soldering :P

Okay, there is nothing good about my soldering, but there was nothing wrong touched (I still hope so...). But the Pi still didn't boot, with or without the pin.

After an hour of trying and retrying to get the Pi working, I ended up with this:

The result

I'm sure I can still solder the cover back, but the Pi still doesn't boot, no matter how I try to press the SD card. I have that nasty solid red led and nothing else.

Can this be repaired?

  • Did you buy it on Amazon? You should be able to return it, check the warranty information however in the book that came with the Pi, it is also good to check on the Official Pi forums to see if they can offer help.
    – BantuTech
    Commented Mar 9, 2017 at 16:36
  • @BantuTech Nope, I bought it on Aliexpress. I live in Russia and China is quite close here ;) Unfortunately, I don't have anything about warranty in my retail box. There are only quick start guide and safety instructions. But is the Pi still applicable for warranty? I've soldered it...
    – Sergobot
    Commented Mar 9, 2017 at 17:12
  • Since nobody else has responded, I would say probably not. Are you holding in the little switch that detects if a SD card is inserted?
    – anonymoose
    Commented Mar 21, 2017 at 22:44
  • since i dont have 50 reputation points but @Sergobot did u find a fix ? because i have the same problem ? Commented Jun 20, 2017 at 20:40
  • @anishsingla A friend of mine, who has better soldering skills than I do, tried to fix the Pi for me but didn't succeed. The card reader looks like new, but still doesn't work. I haven't attempted to fix it since then, and bought a new board. But still, I think it can be repaired, in case I didn't damage anything with the heat of my soldering iron. I can only suggest you to solder it very carefully. If you get it working, please report in here :)
    – Sergobot
    Commented Jun 21, 2017 at 12:12

2 Answers 2


Same problem here, but i alredy figure it out. The problem is there is 2 pin mecanism soldered in the uper right side of the card slot that contact when the card is inserted like some sort of safety mecanism or something. When the metal cover lifted one of the mecanism is detached causing the mecanism to not work. You need to do some micro soldering to the detached pin, the pin is ridiculously small so good luck. I end up broke mine while doing so. I dont know where to find that type of m sd card slot, if anyone know where to find it let me know.

  • I already have another Pi, but thanks for the advice. It may turn up useful for me or someone else in the future. Thanks!
    – Sergobot
    Commented Sep 22, 2017 at 6:31

I ran into the same symptoms as described. I was certain there was a problem with the pins (I pulled the rpi out of a case without removing the sd card). After a lot of trial and failure I decided to check my microsd card to find it was dead. I'm not sure what killed it but my mac wouldn't read it. I install the noobs lite installer on another microsd card I had around the the rpi booted right up.

Not the answer you're looking for? Browse other questions tagged or ask your own question.