I followed this guide to use my pi as a MIDI synthesizer.


Everything worked well until I installed uptsart. Since, my boot screen is stuck to "random nonblocking pool is initialized"

I use a Raspberry Pi 1 Model B with RaspbianLite.

  • 1
    Restore from your backup and do not install upstart. Raspbian uses systemd as do most Debian based systems.
    – Milliways
    Mar 10, 2017 at 0:43

2 Answers 2


That guide was written in 2015, and presumably working on up-to-date Raspbian. You didn't specify which version you are using, but I would try to use the one from https://downloads.raspberrypi.org/raspbian/images/raspbian-2015-02-02/ and see if that one works better.

Note that upstart was abandoned in 2014, so it's quite likely the version you're trying to install now is essentially the same as the one the guide's author used in 2015.


I got the same matter after installing Ustart. I had tried this but it is in vain.


I think the /etc/init doesn't have some necessary scripts or what the boot require for itself to run booting this progress.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.