0

I'm having an issue with my new Pi. I picked the starting project of Stratum 2 NTP server. At a minimum I would like to act as a local NTP server for machines on the LAN. Per multiple sources online I've tried :

/etc/ntp.conf
bash : /etc/ntp.conf : Permission Denied

I've also tried:

sudo su
/etc/ntp.conf
bash : /etc/ntp.conf : Permission Denied

It hasn't been a very good start. I've spent a lot of time modifying visudo after running into this problem and seem to be running down some rabbit holes. If not already painfully clear, I'm new to Linux as well.

Appreciate your time. Jim

  • 3
    You'll need to find a new tutorial. You're attempting to execute the ntp configuration file, which won't happen, as it doesn't contain any code. – stevieb Mar 11 '17 at 19:03
0

This bug was already assessed in an launchpad and GitHub issue request. Just a heads up in the future, a simple google search will bring up some gold results.

The best solution seems to be:

$ dpkg --purge ntp
$ invoke-rc.d apparmor restart
$ apt-get install openntpd
| improve this answer | |
  • 1
    Thanks Braydon. I did spend a significant amount of time googling issues, the underline problem here clearly is user error. I don't understand enough of what am doing to even google the issues correctly. My NTP server is now up and running. – yscustom Mar 19 '17 at 15:43
  • @yscustom It's perfectly fine! I know your issue when I first started. Sometimes google can be tricky with words to get the right result, I hope I didn't come off as rude though. As long as you check first and can't find then post here. I'm glad your issue was fixed. – Braydon Gines Mar 20 '17 at 0:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.