1

I'm using an Adafruit 2.4" Resistive PiTFT on my shiny new Raspberry Pi Zero W and I've finally managed to get the display configured but the touchscreen is proving a problem... (Please note that instead of setting X11's framebuffer to /dev/fb1 to get X11 to show up on the touchscreen, resulting in a tiny desktop, I'm using fbcp from boot to copy the entire display there so I get all fullscreen programs to work, etc.).

When I use ts_calibrate and ts_test, the touchscreen calibrates and works fine, but when I use xinput_calibrator for trying to make the touchscreen work with X11, it makes no difference. I've tried copying the output into /etc/X11/xorg.conf.d/99-calibration.conf (as is required) and then rebooting, but that doesn't make any difference either! Not only that, I can change the SwapXY value and the InvertX and InvertY values between 0 and 1 all I want and it doesn't change the mapping of the touchscreen! All the settings are simply being ignored by the OS and I have no idea why.

  • I have this same problem. Going crazy trying to find a solution. – Bernardo Meurer Nov 12 '17 at 5:40
0

I had similar problems with a raspberry pi 3 and fixed it by interchanging the cal values like this in /etc/X11/xorg.conf.d/99-calibration.conf:

"calibration" "3800 120 200 3900" for /boot/config.txt rotate=270 to "calibration" "120 3800 3900 200" for /boot/config.txt rotate=90

Use your values for the calibration.

However, I upgraded to the new Pixel OS and now nothing seems to work again to fix the pitft touch screen calibration.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.