I installed transmission on my raspberry pi and set it up to download directly onto a mounted external hdd. The drive is mounted using following fstab entry:

/dev/sda1 /mnt/old ntfs uid=pi,gid=pi,umask=000 0 0

I've added the user debian-transmission to group pi and also added user pi to group debian-transmission, just to be safe. The service runs under user pi.

I've tried every suggestion I found here Transmission: permission denied on USB disk but none of them worked.

1 Answer 1


Before we continue, a default Debian/Raspbian installation has read-only support for NTFS. Try installing ntfs-3g for read & write access:

sudo apt-get install ntfs-3g

If this doesn't work right away, make sure to power cycle your Raspberry Pi (sudo shutdown, disconnect all cables, wait 10 seconds, connect all cables and let it boot again).

Then try to make user pi owner of the root folder of the USB device.

sudo chown -R pi:pi /dev/sda1

I don't know how familiar you are with GNU/Linux, but here is the explanation of the suggested commands:

  • sudo => super user do
  • apt-get install => install using apt (the "advanced packaging tool")
  • chown -R => change ownership, -R makes it recursive (includes all subfolders & files)
  • I tried: brw-rw---- 1 pi pi 8, 1 Mar 12 19:48 /dev/sda1 Sadly, it still doesn't work.
    – Ciri
    Mar 13, 2017 at 11:07
  • Can you try to make a subfolder as root (eg. /dev/sda1/transmission), change the ownership for that subfolder to user pi, point Transmission to that subfolder, and then reboot (or restart the Transmission process)?
    – Max
    Mar 13, 2017 at 11:12
  • That didn't work, but I noticed something weird. The folder /mnt/old (whch is the mounting point of sda1) has pi:pi 777 permissions, but I can't write anything as user pi, I have to be root. That doesn't seem to be normal. It may be an issue with the way the drive is mounted.
    – Ciri
    Mar 13, 2017 at 11:18
  • Are you using the default Raspbian NTFS driver? That one is read-only.
    – Max
    Mar 13, 2017 at 11:26
  • 1
    Ah, problem found. I was missing the proper drivers for ntfs. Installing the package ntfs-3g did the trick.
    – Ciri
    Mar 13, 2017 at 11:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.