Hello wonderful people of the internet, I hope you're having a wonderful day! I was recently given a raspberry pi(1) model b, I bought a 16GB sd card for it and I've installed raspbian onto it. I have booted the pi and I've resized the file system. It works flawlessly, until I get to upgrading. I initialize the sudo apt-get update (sometimes it finishes that but it fails when upgrading) it completely freezes. All I can do is to unplug it and plug it back in. I've tried leaving it over night, and in the morning it was still frozen. On raspbian Light, it finishes the update, but once I try to upgrade it does the same. It gives absolutely no error, it just freezes, Can't move the mouse, doesn't respond to any keys, it completely freezes. Why could this be? How should I be diagnosing a problem like this? What can be done to finish it's upgrade cycle?

P.S. I'm using the latest raspbian as of Monday, March 13, 2017

P.S.S I've tried using numerous power supplies, the one I'm using now is a 400w atx psu from a pc.

  • 1
    You have provided minimal information. How are you "upgrading"? Include output of sudo apt update in your question. Incidentally ATX is inappropriate for the Pi. It only runs when enabled; the standby should run a Pi, but using a 400W supply for <5W seems inefficient. – Milliways Mar 13 '17 at 23:22
  • By upgrading I mean upgrading with the sudo apt-get upgrade. It usually stops at libreoffice. The psu is running(not just plugged in, green and black wires connected, fan spinning), definitely, and giving out a healthy 5V on the 5 volt rail. I just use it because it's the most powerful thing I have, because at a point I thought that it might be starving for power. I have a 2 amp switch mode psu that I was given with it, but it does the same with both power supplies – R4MP4G3RXD Mar 14 '17 at 17:41

This sounds like a IO error to me. Are you sure that the SD card is definitely OK - can you swap it out (try copying the disk to another with the disk imager) with another to confirm.

Assuming its not a physical error, its could be a filesystem error. run a fsck on the disk from the terminal.


That said, I would expect file system errors to be returned to you rather than hanging the Pi so it is likely to be an overheating or power fluctuation (during intensive disk IO) issue.

@Milliways is bang on the money - why are you using an ATX power supply? 5V is not just 5V it has to be very stable for the Pi (unlike for example on a hard drive in a normal PC), especially under load.

Try using a properly regulated USB power supply - like the one the Raspi Foundation recommend https://www.raspberrypi.org/documentation/hardware/raspberrypi/power/README.md or a good quality 2A USB charger (Nokia chargers are known to be reliable for this).

EDIT: Following up on your comment above about power supplies, let's assume for now the power supply is good and you have checked the file system and eliminated a faulty SD Card - to me, there is only one thing left - the Pi itself.

You said it was given to you - perhaps it has been cooked or otherwise damaged at some point. The only real way forward (after what I have already suggested) is putting that card into another Pi1b and seeing if it does the same. The fact you were given this one implies that you don't have another one to test it against but in unpredictable hardware situations like this, swap-and-drop is the only option you really have.

Of course, you could just invest the £30 in a brand new shiny RPi3 - It would be quicker, 'known good' and save you a lot more hair pulling.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.