15

I'm using Raspbmc RC3 to play some 720/1080p content over NFS and AFP. I experience frequent sound drops, every 2-3 minutes or so the sound drops for 1-2 secs.

I've set XBMC to forward Dolby/DTS to my capable receiver, and set audio mode to 5.1. Any ideas?

11

First, stop xbmc

pi@raspbmc:~$ sudo initctl stop xbmc

go and get fbset

pi@raspbmc:~$ sudo apt-get install fbset

take a look to the current framebuffer settings

pi@raspbmc:~$ fbset

mode "1920x1080"
    geometry 1920 1080 1920 1080 16
    timings 0 0 0 0 0 0 0
    rgba 5/11,6/5,5/0,0/16
endmode

enable hardware acceleration, maybe to improve the xbmc GUI rendering and to enjoy some 3DDemos quite faster, dunno if the accel is needed but why not giving a try to learn something

fbset -accel true

now take a look again

pi@raspbmc:~$ fbset

mode "1920x1080"
    geometry 1920 1080 1920 1080 16
    timings 0 0 0 0 0 0 0
    accel true
    rgba 5/11,6/5,5/0,0/16
endmode

ok, let's get git and build-essential

pi@raspbmc:~$ sudo apt-get install git build-essential

clone the raspb firmware, this takes a lot of space ! ~600mb

pi@raspbmc:~$ git clone git://github.com/raspberrypi/firmware.git

now lets move some files where they should be

pi@raspbmc:~$ cd firmware/opt/vc
pi@raspbmc:~/firmware/opt/vc$ sudo mv bin /opt/vc/
pi@raspbmc:~/firmware/opt/vc$ sudo mv include /opt/vc/
pi@raspbmc:~/firmware/opt/vc$ sudo mv sbin /opt/vc/
pi@raspbmc:~/firmware/opt/vc$ sudo mv src /opt/vc/

tell our TV to switch to 1080p24 but first have a look to the supported resolutions of your TV

pi@raspbmc:~/firmware/opt/vc$ cd /opt/vc/bin
pi@raspbmc:/opt/vc/bin$ ./tvservice --modes=CEA
Group CEA has 15 modes:
           mode 1: 640x480 @ 60Hz, progressive
           mode 2: 720x480 @ 60Hz, progressive
           mode 3: 720x480 @ 60Hz, progressive
           mode 4: 1280x720 @ 60Hz, progressive
           mode 5: 1920x1080 @ 60Hz, interlaced
  (native) mode 16: 1920x1080 @ 60Hz, progressive
           mode 17: 720x576 @ 50Hz, progressive
           mode 18: 720x576 @ 50Hz, progressive
           mode 19: 1280x720 @ 50Hz, progressive
           mode 20: 1920x1080 @ 50Hz, interlaced
           mode 21: 720x576 @ 50Hz, interlaced
  (native) mode 31: 1920x1080 @ 50Hz, progressive
           mode 32: 1920x1080 @ 24Hz, progressive
           mode 33: 1920x1080 @ 25Hz, progressive
           mode 34: 1920x1080 @ 30Hz, progressive
pi@raspbmc:/opt/vc/bin$

ok mode 32 is the one for me what i was looking for

pi@raspbmc:/opt/vc/bin$ ./tvservice --explicit="CEA 32"
Powering on HDMI with explicit settings (CEA mode 32)
pi@raspbmc:/opt/vc/bin$

let's check

pi@raspbmc:/opt/vc/bin$ ./tvservice -s
state: HPD high|HDMI mode|HDCP off|composite off (0x12001a), 1920x1080 @ 24Hz, progressive
pi@raspbmc:/opt/vc/bin$

yeah done, start xbmc

pi@raspbmc:/opt/vc/bin$ sudo initctl start xbmc

enjoy flicker free movies like a mediacenter should do

oh, and try out the demos in /opt/vc/src !

  • 1
    wow fantastic answer! – Piotr Kula Jul 31 '12 at 15:59
  • 1
    I see you install build-essential, but then I don't see you use any build tools. Are the binaries in the git check out, or did you miss the make command? – KayEss Aug 16 '13 at 2:07
8

I've solved it: Set video at 30Hz, do not adjust rate to match played files. Turns out enabling passthrough, BUT setting audio at 2.0 gives me uninterrupted 5.1 AC3 and DTS on my receiver!

  • Well done, nice work :) – Jivings Jun 25 '12 at 12:28
  • I will in 4 hours - can't accept it yet – Sjaak Trekhaak Jun 25 '12 at 12:40
  • I've also sorted it for 60Hz - I overclocked my Pi's cpu_freq to 900 and gpu_freq to 350. – Sjaak Trekhaak Jul 23 '12 at 7:21
  • * arm_freq instead of cpu_freq – Sjaak Trekhaak Jul 23 '12 at 12:23
1

I solved it by editing the file ~/.xbmc/userdata/guisettings.xml and setting to true these properties:

<dtshdpassthrough default="true">true</dtshdpassthrough>
<dtspassthrough default="true">true</dtspassthrough>
<dualaudio default="true">true</dualaudio>

Hope this can be useful for someone.

Greetings,

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.