I am trying to get audio output to a USB headset that is plugged into my pi zero. The headset can be seen and selected in the audio GUI and seen using aplay -l. However, there is still no sound output. Do I require a soundcard or similar device? Thanks

  • raspberrypi.stackexchange.com/questions/44/… Check out the help from this thread.
    – BantuTech
    Mar 17 '17 at 12:23
  • Welcome to the Raspberry Pi flavoured corner of the Stack Exchange Network. You have got the volume turned up and the output is not marked as "muted" right? 8-) I see on my RPi I have the following that can control the sound levels: {command line UI}: alsamixer, pimixer; {GUI}: alsamixergui; {command line, direct get/set properties}: amixer. I'd give alsamixer a shot first of all...!
    – SlySven
    Mar 18 '17 at 19:33
  • Hi did you manage to make it work after all? because Im thinking about using micro usb headset with my pi Zero as well. Aug 24 '18 at 16:02
  • 1
    @NouranS.Ahmad Hi. Yes, the headset did work. It happened to be an issue with the USB hub that I was using. Once I plugged the headset into a specific port on the hub it worked fine. Since you don't need a hub for a micro USB headset I don't see why you would have issues. Best of luck.
    – ajflj
    Aug 24 '18 at 16:06
  • Just to point out something the micro usb headset didnt work, I tried more than one brand as well, so I ended up using a bluetooth headset. Oct 28 '18 at 10:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.